V3 Scheduler popup

Anki version 23.12.1

There was a recent upgrade to Anki and ever since installing that I have been getting a message saying “Your collection needs to be upgraded to the V3 scheduler”.
The options offered are “Learn more” which takes you to a help page and “Upgrade”. Click on that and then there is a message “Scheduler Updated Successfully” when the popup message then goes away.

This is then repeated the next day when I log back in to Anki.

How do I get the system to remember that I have accepted the V3 upgrade?

I haven’t dealt with the pop-up, but have you tried turning the v3 scheduler on directly in Preferences - Anki Manual ? Then probably restart Anki.

I can find Preferences and have looked through all five tabs. I do not see ‘Anki Manual’ (or anything related to the Scheduler version). I am using a computer and so the Desktop version if that makes a difference …

You have version 23.12.1, so this is not relevant to you.

The v2 scheduler is no longer supported in Anki since version 23.10.

In older versions of Anki you could switch between v2 and v3 through the menu, under Tools / Preferences / Review.

Regarding the problem you reported, I’m not sure. Are you also using Anki on another computer or a mobile phone? See below.

Someone else reported the same problem, and the solution turned out to be using “Tools / Check database” after pressing the Update button.

There is nothing to switch between V2 and V3 under the menu Tools / Preferences / Review.

However, I read the second message and have clicked on Check Database. I will hope that this fixes the problem but it will be on tomorrows session that I will find out. If the problem remains I will post back.

Thank you for your help.

In my case, this always happens when I open Anki the next day. I tried all the tips you placed here, but the problem still persists. That never happened before, it began when I updated Anki to the new version. Anyway, if you or somone else can help me, I will be greatful.

In the other thread that I linked to, you seemed to indicate that “Check database” had worked for you.

Just in case an add-on is involved, try quitting Anki and restarting it while holding down the Shift key to disable all add-ons, press the Update button and do “Check database” again, then quit Anki. Then try restarting Anki and see if it asks you to update again.

Also, are you using Anki anywhere else? On another computer, or on an Android phone?

Sorry to confuse, I have clicked on ‘Check Database’ but it will only be tomorrow when I start Anki again that I will know whether or not it has had any effect (or whether I have to do it again). (no point in starting Anki now since this event only happens when Anki restarts the ‘Next day’ counter.

I do also use Anki on an Android phone and very infrequently on an Android tablet.

I was replying to @Vinicius.Ribeiro above, he posted in the other thread that I linked to above, and he had the same problem. He has now posted in this thread as well.

From the other thread, I thought “Check database” solved it for him, but apparently not.

Let us know if it works for you tomorrow.

I just started Anki this morning and there was no scheduler pop-up message. So it sounds a bit like clicking on ‘Check database’ was a necessary step to solving the problem …

1 Like

Well now for the strange twist … I have just started up Anki again on my Desktop (was on my Android phone earlier and Desktop before that). On this occasion the pop-up is back.

So what has changed … well basically nothing but the timing is different.

This sounds like the same thing that apparently happened to Vinicius.Ribeiro above: a temporary solution, then the problem came back.

Any idea what might have happened between the two dates? For example, could using AnkiDroid in the meantime have triggered the problem to come back?

What version of AnkiDroid do you have? Maybe you could try one of the recent 2.17alpha versions.

1 Like

Instantly this just became interesting … I have literally just finished clearing off all my Decks for the workload today so I closed Anki with a column of zeros under the Due heading. I closed Anki and went to email and saw your message.

So I then opened Anki on my mobile phone to find the version number and immediately I noticed that there were two decks with Due items. How can that be … the two platforms are supposed to by synchronized. The version is 2.16.5.

So I closed the mobile and reopened the Desktop version to see if the Due items now appeared. Actually not, but the pop-up did. Closed Anki.

I then opened the Android version and clicked on Check database. It did and deleted 2MB of something. The Due items were still there afterwards. I closed Anki and went back to the Desktop version and the Due items were still absent.

I have not seen this difference in synchronization before and I do often switch between the two platforms.

I thought that worked when I followed the tip on that moment, but I was wrong. Every time I open Anki next day, that message with 2 buttons appears. About the add-on, I already removed it before I see that message. It was Anki Zoom, but unfortunately, it still continue to happen.

It did not work, as I replied to you on the previous message.

Just looking at what happens … so I opened Anki on my Android Tablet. I do not normally use Anki on the tablet but I do sometimes. It had been a while and when I synced the collection there were a lot of changes downloaded.

When Anki fully opened and listed all the Decks, the same two Decks that had Due items was the same as my Android Phone. However, my Desktop version still shows no Due items and pressing Sync did not change that status.

That is pretty normal if you’re still using v2 in AnkiDroid – The Anki v3 scheduler - Frequently Asked Questions . I don’t think it’s a sign they’re out of sync.

I’d recommend enabling v3 on AnkiDroid though (directions on linked page). I’ve been using it in 2.16.5 for over 6m with no issues.

(No idea if it will help clear the pop-up issue.)

Amazing, I had in my mind assumed that everything would be V3 scheduler until I read your message. So I looked at my phone and saw that I could indeed enable the V3 scheduler but I also read the difficult to miss warning message that said my life would perhaps be full of unhappiness if I did. So I think I will skip on this update until it is stable.

That warning scared me off for a few months too, but it’s been smooth sailing since I switched it on.