Filtered Decks issue

i have been noticing that once i have created a filtered deck and hit “good” the card goes back to the original deck even tho i did not empty the deck? even the parameters for the filtered deck are just set to specific uworld tags (i did not make it based off weather the card is new or learning). I do not want this to happen and want those cards to stay in the filtered deck i created. This started happening when i switched to FSRS. before the cards would just stay in the filtered deck the next day and I could study the from there (which is how i like to do it).
Is there a way to fix this?

1 Like

Cards automatically return to their home deck after they are studied in the filtered deck.
Filtered Decks - Anki Manual

Filtered decks are not intended to be a permanent new home for a card. Once they’ve been studied, and return to their home deck, you can only bring them back to the Filtered deck with a Rebuild.

It might seem that way, but FSRS hasn’t changed anything about that behavior.

If you’re trying to permanently study these cards together – perhaps on a rotating schedule … with gradually increasing intervals … :sweat_smile: – you should move them into a new (standard) subdeck together, via “Change Deck.”

yeah i don’t think it has to do with fsrs either but it just started happening once i made the switch. The settings i have put on my filtered deck are “reschedule based on answers in deck”. so there’s literally no reason for it to go back to the parent deck as i did not even click empty or reset.

i build this filtered deck based off uworld quid’s that’s it no other command is there such as (is:learn or is is:new)

this gets really frustrating for me because i like to go back and search in the filtered deck for the close:2 or close:3 of different cards so i can suspend them if i don’t think i need it in order to essential decrease card load. now i can’t do that because when i search in the deck a lot of cards have been moved out back to the parent deck so i don’t what I’m suspending or unsuspending.

Take a screenshot of your filtered deck settings.

I think you misunderstand that setting. It means “treat the studying I’m doing here just like you would if I were studying these cards in their home deck.”

Once you’ve studied the card the appropriate number of times (based on whether it is New, Review, lapsed into Relearn, etc.) – yes, there is a reason it will return to its home deck. That’s the correct behavior. It will be rescheduled to a new due date based on the outcome of your study.

The simple solution is – don’t use filtered decks for that. Take whatever your search filter is for that deck, and put it in the Browse window. Then you can add more search terms to narrow that however you want. Searching - Anki Manual

no i understand what it means I’m just mentioning it because if you do not click “reschedule on change” there in the options you can state that if you hit good it will return back to the original deck. (as i have shown in the uploaded photo)

i don’t understand how that’s a solution. filtered decks are meant to help filter studying to focus on specific cards. and as i stated before this was never an issue until recently so I’m confused why everyone i have asked so for saying that this was always the norm?

i think one thing i can try is adding a second filter and putting is: learning is:new is: review so all the cards with those uworld tags in every state stay in the filtered deck. but again i never had to this before and i don’t see what anki changed to make it behave differently (like if there was a setting stating it)

Why? That purpose is already served by normal decks. You don’t need a filtered deck that is pulling cards from a different deck to do that. Just create a new deck, use that search in the browser, select all, change to a different deck.

Filtered decks also don’t allow a preset so you are forced to use the settings of main deck.

Did you maybe try something different than you’re doing now? As long as I can remember, that’s how filtered decks have worked. If you turn off reschedule only then the cards don’t return to their decks.

Oh, I think you’re misunderstanding this. if you turn off “reschedule” then the cards DO NOT return to their original deck.

if you do not want the good button to return the cards back to the deck, do not set 0 in the parameters for it.

1 Like

You are correct that if you choose not to reschedule-based-on, you’ll get different behavior. You can choose what buttons will send the cards back to their home decks, and what buttons will reshow the card after a certain delay.

Let’s start there. How long have you been using Anki?

Previously, it was necessary to set up steps in filtered decks, just like learning steps. Now we prescribe the time for each button and if we write 0, then this button will return the card back to the deck. That is, previously, if you removed the rescheduling, then the card could not get back into the deck in any way. Except the easy button.


nope i am not doing anything differently as to before. and to answer the first question the reason is because i use the anking deck which is divided based on tags so i its really helpful to make filtered decks based on the tags themselves

i leave “reschedule cards” on on i just sent that screenshot as an example

yeah exactly so if i hit good for one day then i should see. it next day in the filtered deck as i used to no? i have been using anki for 3 years now. i feel like this issue may have started once i started using fsrs because i changed the learning step as recommended to just 20 minutes compared to before when i had 2 learning learning steps (but this is just an assumption i have no idea whats going on)

i keep the scheduling on

If you keep rescheduling on, pressing Good will make the card return to it’s original deck. If you turn that off, it will keep repeating the step you set for Good, i.e., it will keep coming back after the time you set elapses.

1 Like

There have been changes to filtered decks over the years. It’s possible that you were using the v1 scheduler when you started – but support for that ended more than 2 years ago. That was the last time “custom steps” could be assigned to a filtered deck.

Since then, using the v2 and v3 schedulers – if you have rescheduling on, the cards return to their home decks after studying. I confirmed that the manual has said that at least since March 2020.

That depends. If you have a 1d learning/relearning step, then a card in Learn/Relearn will stay in the filtered deck until it completes that step and graduates to review. But for a Review card – no, it won’t stay in the filtered deck.

How long was your other learning step?

1 Like

yeah so my issue is that until before i switched to fsrs it did not return to the original deck even when “resechuled cards” was turned on

my old learning steps were 25 minutes and one day