Emergency: FSRS extremely long intervals even with correct settings on NEW cards

Hi. I implemented FSRS recently with a learning step of 10m, retention factor of .97, and default parameters.

All was working fine until I wanted to do it on my IOS. I updated the app to the most recent version, and then manually changed all the retentions and parameters for each of my subdecks on my IOS to match the ones on my PC.

After I did this, I clicked a completely new card, and the first ‘good’ step (again on a completely new card) is 4d on the first click. I think it has something to do with whatever I did on my IOS.

I tried to do a force sync in one direction from my PC to my IOS, but this did not solve the issue. I would appreciate any help. Thanks

pictures for reference:

it is a new card:

the first ‘good’ is 3d and on other cards it is 4d

Is the deck actually using a preset with that learning step, FSRS enabled and your parameters in? What are the parameters (IIRC, the first 4 numbers are the initial stabilities)?

Is this you too? Reddit - Dive into anything

If so, I won’t repeat my answer here.

The only difference between it being 3d and 4d is fuzz factor. Studying - Anki Manual

yes @Aleksej . parameters are the default ones from the github, learning step is 10m, and FSRS is enabled with a retention of .97

it was working 2 hours ago until whatever I did on IOS

I don’t know what’s up with the learning step, but if you have at least 1000 reviews in your deck, just use the Optimize button to get better parameters.

this isn’t a fuzz factor issue. if you look closely, you’ll see that this is the first learning click.

I have never seen this new card before. I clicked spacebar. It says 3d for ‘good’. this is not normal or fuzz factor. to add to that, like I said on reddit - stop treating me condescendingly. you know what you are doing. it’s cringe.

unfortunately I only have 900 reviews so I have to use default for this subdeck. i’m not sure what the issue is, but I can list what I’ve tried.

I turned FSRS off, which changed the ‘good’ button to 1d

I kept FSRS on and changed the learning steps to insanely wild numbers, and nothing changed. I changed the retention factor, nothing changed. so I think the issue is something with FSRS is stuck

If you want to keep using FSRS, try copying the default parameters and making the first four numbers smaller.

You said it was a subdeck. So do you have more reviews when combined with other decks?

just changed it from default to this. did not change a single thing. I think there’s some sort of bug that has to do with whatever I did on IOS, i’m not sure what though

0.3000, 0.8000, 2.0000, 8.9000, 4.9300, 0.9400, 0.8600, 0.0100, 1.4900, 0.1400, 0.9400, 2.1800, 0.0500, 0.3400, 1.2600, 0.2900, 2.6100

yea I have more reviews when combined with other decks, but those other decks are a good bit harder and would ruin the parameters for this easier deck

If you have good backups, you can try this:
Put the easiest cards (with 100 reviews) from another deck into a subdeck, and put the two subdecks under the same temporary parent deck, then optimize with the 1000 reviews, that are mostly from this deck.
That probably won’t fix the issue though.

I see. but what if the parameters aren’t the problem (since changing them to wild numbers isn’t changing anything?)

also, it seems my post got hidden for saying the word “d*mn”. how do I unhide it

Did you put the FSRS code into Custom scheduling? That’s not needed in the current Anki.

what is “the FSRS code”

sorry I’m not familiar and I appreciate the help

Before Anki 23.10, FSRS was not a part of it, and you would put JavaScript code (text that programmers wrote in the programming language JavaScript) into a field in the preset.

Do you have any add-ons installed?

I have add ons and got the FSRS add on yesterday but not sure what capabilities it has or anything.

I read this on the FSRS guide, and do not see different intervals when I put .7 and .99 retention, so FSRS is broken I think for me. Not sure why:

How can I confirm that FSRS is working?

Review a new card, remember what intervals you saw above the answer buttons. Undo review. Now set the desired retention either to 0.99 (maximum) or to 0.7 (minimum), and review the card again. You should see different intervals.

@Aleksej it won’t let me comment anymore because I’m a new user but to answer your latest question:

Yea I don’t see a difference when I change from .99 to .7 or when I change parameters or learning steps.

I have like 50 add ons. All the anking default ones from that one video, the FSRS add on, heatmap, etc. But that was all working fine before.

I’m very confident whatever I did on IOS is what’s breaking it. some sort of bug or something. on IOS, I manually re-input my FSRS retention and parameters after updating the app, which I read isn’t supposed to be needed since it should auto bring param and retention factor from ankiweb.

@Aleksej yea I’d think it is that too, but it was working literally 2 hours ago before whatever I did on IOS. so I’m ruling that out for now because I didn’t install any new addons since then and know I don’t have any special scheduling addons.

I genuinely believe it’s whatever I did on IOS. Is there a way to revert what I did on my phone or just clean slate it or something?

@Aleksej yes, it broke on IOS as well. as new info that I just found out. I restored to a backup from 3 hours ago (so before the IOS bs I did) and it fixed it (but I’ll have to redo 200 reviews.

optimally, I’d like those 200 reviews to count. is there a way to do that, and also fix this IOS problem for the future (because I def need to be able to click cards on my phone).

at least though this isolates the problem for sure. it’s whatever I had done on IOS (which was manually setting my retention and parameters there). some sort of glitch that the maker of FSRS should look into maybe? idk

@Aleksej it’s got all the addons, cards, etc. a full backup. again I appreciate the help this late.

@Aleksej I see. How can I take my newest version of reviews/cards (without the FSRS settings for it since I think that’s what is messed up) and overlay with my old addons?

FWIW, I don’t remember an add-on updating. Like I’m deadly confident my phone is what messed everything up. I’ll be trying to fix this like the above para says on my pc, so whatever solution works on a pc would be insanely appreciated

@Aleksej I appreciate the help. honestly, it’s only 200 reviews (1 hour or so of work). I’d rather play it safe. I remember the feeling of hopelessness when it wasn’t working and i’m insanely tired rn (3 am where I live), so if I break it again I think I’ll lose all hope. So I’ll leave it where it is.

I’d love if anyone could comment though on how IOS FSRS is supposed to work and how to actually fix/prevent this problem in the future, it seems like a giant bug/break.

Again. I appreciate the time and constant help @Aleksej it’s meant a lot with how tired and tilted I am rn.

also p.s for anyone reading all this: do you not see how incredibly stupid this rule of new members can’t respond a lot is. lmao

@dae so you mean to tell me that upon first seeing a new card, and clicking space bar once without ever learning the card, it should say 3-4d? how does that make sense?

and how does that work considering that my backed up verison, which is correct, has the first ‘good’ as 10m, and the second one as 2 or 3 or 4d depending on fuzz factor.

I appreciate the help but I don’t think that’s correct

What add-ons do you have?

Yes, you should.

You don’t actually have to enter the FSRS parameters to use the default ones. Just leave the field empty.

But there may be add-ons that add their own scheduling algorithms, or just break something because Anki has changed.

I don’t have iOS and have no idea what the cause could be if it isn’t an add-on. Did it break on iOS, too?

(I can’t post more than three consecutive replies.)
What does the backup contain? Only the collection, or also the add-ons?

So maybe it’s the add-ons. Maybe an add-on was updated and broke things. If you have a backup of the new state of the collection (cards), you can import it into your Anki, or put the add-ons from the old backup into the Anki from the new one. But I don’t know what it looks like on iOS or other Apple software.

You could import the whole collection (new state), but that includes the settings: Backups - Anki Manual
Or you could export the cards you reviewed from the profile (new state) into an .apkg file. You can select the cards rated today using “rated:1” Searching - Anki Manual and export them, then import them into the old-state Anki, overwriting the review history with the new one.
That is unless a database or something is actually damaged. Then I don’t know.

The rule is probably to prevent spam.

AnkiMobile 23.12.1 and Anki 23.12.1 use the same FSRS code. This means:

a) provided you have syncing set up, you can make any changes you want on one device, and sync them to the other - you don’t need to make the same settings changes on each device.
b) any behaviour differences you see will be a result of the changes you made, and not differences between computer and mobile client

3/4 day delays sound normal with the default FSRS presets and fuzzing - @Danika_Dakika’s original reply on the reddit post looks correct.