Emergency: FSRS extremely long intervals even with correct settings on NEW cards

Context: my learning step is 10m, retention is .90, default parameters from FSRS guide.

Upon clicking ‘space bar’ for the first time when learning new cards, the first step is 15d. I changed the retention factor to .7 and .97 like the guide says to test, and the learning step does not change. So I know FSRS is broken. I have to use default param becauase only 900 cards in thus subdeck.

I am confident this is not fuzz factor. Fuzz factor applies to cards on the second ‘good’ click, not the first ‘good’ when you literally first see the card.

I attached pics of my settings so it can be seen that it’s all normal like the guide says. Any help is greatly appreciated, I am very tilted since I’ve been trying to setup FSRS for like 3 days. Also if there is a way to just clean reset FSRS with my card settings again, I would do that too if possible.

@tiviskan thanks for the help, responding here because I have a response limit as a new account.

just tried to leave it clear with those param. still get 15d.

also can a mod or something give me the ability to respond? I promise I’m not a spammer or whatever

@vaibhav thanks for the help.

I do have different subdecks. I read on the anki reddit that all subdecks should automatically have the same retention factor because that is global. is that true? somehow, it let me change the retention factor for each subdeck individually, which I think is a sign of how broken my anki FSRS is. so to answer the question, no, my subdecks have different retention factors, because it is making me manually put in each retention factor for each subdeck (instead of globally setting a retention factor). how do I fix this if it is the problem?

@vaibhav ok so it seems like I’m inputting everything correctly then. so why is my first ‘good’ click showing 15d? again thanks for the help

@vaibhav the screenshot is from that particular subdeck’s preset

@Keks and everyone else. SOLVED.

we tried the addons thing didn’t fix. it

we solved it. we as in claritymindness mostly. the issue was that the preset I put for my overarching deck was not applying to each subdeck. and as an FSRS beginner, this was not very clear to me from the guide.

claritymindness made a post to ask to try and improve this for other beginners.

As far as I know the default parameters are the ones that show up in faded text when you leave the FSRS parameters blank. These are the parameters I get in my version of Anki:


You could try clearing the field entirely (save the parameters somewhere else if you want to recover them later) to see if that helps.


Do you have subdecks? If yes, do all of the subdecks have the same preset?

FSRS uses parameters from the subdeck in which the card is located. If your subdecks have wierd parameters, they can cause this issue.

It is also applied to the first Good press. However, fuzz can’t be responsible for this issue because fuzz can cause a 4 day interval to become 2-6 days (approx) but not 15 days.

1 Like

Not true if you have created a preset other than the default one at any point of time (since you have started using Anki)

Also, note that desired retention and parameters are independent of each other. The above holds true for both but I hope that you are not confusing between these two values.

Do you want to make them different? If yes, then all good. If not, you can change the presets of the subdecks so that all of them have the same preset.

Read more about it in the manual: Deck Options - Anki Manual

If subdecks having presets with different parameters is not the issue, then I don’t know what the issue can be. I will let the developers to take over.

1 Like

The final suggestion from me would be to check which subdeck contains this particular card and then share the screenshot of the FSRS settings of that particular subdeck.

1 Like

@L.M.Sherlock can you take a look? Changing desired retention doesn’t affect intervals, and as this user said on Discord, disabling all add-ons didn’t help him either.
EDIT: apparently reinstalling Anki and restoring the collection from a backup doesn’t help him too.
EDIT 2: nevermind, it was a preset problem. This user didn’t apply the preset to subdecks within a parent deck.


You’re wrong.

As you can see in the screenshot, your settings are not by default. Since the weights are changed.

Do you have addons disabled?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.