Copycat Importer (AnkiApp/AnkiPro)

Downgraded to 2.3 and was able to successfully import my deck :+1:

These are special characters added to the error message by Anki.

I had the same issue, and downgraded to 2.3, but in xml zip import I also had an error of missing media

Hi, I am using Copycat Importer with the AnkiPro export helper for the login portion.

After importing, I can see that the flash card Note Types are imported.
However it will always fail to import any cards in my active AnkiPro deck “Imported 0 cards”. I have tried logging in and out of Anki Pro a few times as well as uninstalling/reinstalling Anki and retrying but no luck. Any advice?

Are the decks imported from the AnkiPro Library perhaps? The add-on doesn’t support importing such decks. If that’s not the case, please share your login details with me privately and I’ll have a look.

Hello, I hope I’m posting this in the right place. I have an error importing from AnkiApp. I saw a similar posting on the add-on page but couldn’t find the solution here on the forums. I can login to AnkiApp through the add-on, but it fails when I try to “import.”

Error message below:

Anki 24.04.1 (ccd9ca1a)  (ao)
Python 3.9.18 Qt 6.6.2 PyQt 6.6.1
Platform: Windows-10-10.0.19045

Traceback (most recent call last):
  File "aqt.taskman", line 142, in _on_closures_pending
  File "aqt.taskman", line 86, in <lambda>
  File "C:\Users\thoma\AppData\Roaming\Anki2\addons21\2072125761\gui\dialog.py", line 56, in on_done
    count, warnings = fut.result()
  File "concurrent.futures._base", line 439, in result
  File "concurrent.futures._base", line 391, in __get_result
  File "concurrent.futures.thread", line 58, in run
  File "C:\Users\thoma\AppData\Roaming\Anki2\addons21\2072125761\gui\dialog.py", line 51, in start_importing
    return importer.do_import(), importer.warnings
  File "C:\Users\thoma\AppData\Roaming\Anki2\addons21\2072125761\importers\ankiapp.py", line 413, in do_import
    return self._import_cards()
  File "C:\Users\thoma\AppData\Roaming\Anki2\addons21\2072125761\importers\ankiapp.py", line 320, in _import_cards
    self.mw.col.models.add(model)
  File "anki.models", line 205, in add
  File "anki._backend_generated", line 1077, in add_notetype_legacy
  File "anki._backend", line 173, in _run_command
anki.errors.CardTypeError: Card template <U+2068>1<U+2069> in notetype '<U+2068>Basic (Card 1)<U+2069>' has a problem.<br>See the preview for more information.

===Add-ons (active)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
Copycat Importer AnkiAppAnkiPro ['2072125761', 2024-05-28T05:28, 'None', mod]

===IDs of active AnkiWeb add-ons===
2072125761

===Add-ons (inactive)===
(add-on provided name [Add-on folder, installed at, version, is config changed])

I should add that it downloads all the decks in my AnkiApp library but none of the cards.

Can you share your login details with me privately?

Sure, email?

Yes, that will work.

Same issue for me as well, ankiapp login goes through and decks will import but no cards will appear along with the error message “Anki encountered a problem.”

The AnkiApp error should be fixed now.

3 Likes

Worked perfectly this time!! many thanks for the quick and timely update :slight_smile:

2 Likes