Why are deck options not honoring my Display Order settings?

In my deck options, for New/review order, I’ve selected for new cards to be mixed in together with review cards, but this setting is not being honored (since updating to V3 scheduler, across all Anki versions over the past few months).

Is this a bug? Or am I using contradictory settings?

Note: these are the settings for the parent deck. All sub-decks also have “Mix with reviews” selected.

This probably isn’t the issue, but have you considered changing the settings to make the big yellow warning box go away, and to eliminate that as a possibility?

In other words, change:
New Cards / Insertion order → “Sequential”

and then possibly also:
Display Order / New card gather order → “Deck then random notes”
Display Order / New card sort order → “Order gathered”

Please note it does not apply to intraday learning cards - they will always come first if they are due.

You were right - that was not the issue.

This is not a helpful answer. As you can see from my original post, “All sub-decks also have ‘Mix with reviews’ selected.”

1 Like

The issue is not specific to intraday learning cards. It affects all learning cards.

In other words: I have selected to learn 30 new cards per day, and selected “Mix with reviews,” but instead of mixing my new cards with my review cards, Anki will show me all of the review cards first, and then only start showing me new cards as I approach the end of the session.

Your review sort order is by “Due date, then random”

Is it possible that you have a backlog of overdue reviews? I’m not sure, but perhaps those would show first, before any new cards.

If you search for prop:due<0 in the Browse window, does it show any results? If so, those are overdue reviews.

With those settings, new cards should be evenly spaced through your reviews. If that’s not what you’re seeing, can you reproduce the problem with all add-ons disabled? Are you performing any actions during review like burying/suspending cards?

No, this is not the issue.

Only rarely, like once out of every few hundred reviews.

I tried restarting Anki with add-ons disabled, and I think the problem went away (ie I did about ten reviews, and then a new card showed up)!

Here’s a screenshot of the add-ons that I have enabled:

Mostly they don’t seem like they would be messing with the scheduler at all, perhaps with the exception of FSRS4Anki Helper. Do you think that could be it?

Here’s my Anki version information:

Version <U+2068>23.10.1 (fac9e0ee)<U+2069>
Python 3.9.15 Qt 6.5.3 PyQt 6.5.3

This is on MacOS 13.6.1 (Intel). I have not seen the issue on iOS.

I just confirmed that the problem seems to be caused by the FSRS4Anki Helper add-on. Process:

  1. Booted Anki with add-ons enabled
  2. Ran through around 20-25 reviews and got no new cards
  3. Disabled FSRS4Anki Helper and rebooted Anki
  4. Studied around 10 reviews before getting a new card

Here are my FSRS4Anki Helper settings:

It’s caused by auto-disperse: [BUG] Cards of same note show in succession during review · Issue #205 · open-spaced-repetition/fsrs4anki-helper · GitHub

@L.M.Sherlock if it’s not practical to shift that to the end of reviews, could you please document the downsides of turning it on, so that users know what to expect?

Doc/disable auto disperse by default and warn user · open-spaced-repetition/fsrs4anki-helper@cc499d1 (github.com)

1 Like

Quick update: I see that the problem does go away when I turn off the setting to auto-disperse siblings (but just for anyone else reading and/or debugging - my issue is not directly related to sibling cards at all).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.