While studying, "To Review" number suddenly goes to 0

When studying, my “to review” number suddenly zeroes out. This happens every time. I’m using version Version ⁨2.1.60 (76d88073)⁩, with Python 3.9.15 Qt 6.4.2 PyQt 6.4.0 on my Windows 11 PC. Because I noticed the number going to zero at an unexpected time. I kept track at my next study session. The numbers are in the same order as at the bottom of the screen: new, learning, to review. Here are the entries surrounding the sudden zeroing out: 12 9 46, 12 9 45, 12 8 0, 11 9 0. Note that the number unexpectedly goes from 45 to 0. Because this happened, I missed out on reviewing 45 cards. I believe this is a bug. Is anyone else experiencing something like this? If this is a bug, how do we report it? Thank you.

Probably buried cards:


Thank you. I read the info in your links:

The 2nd one says, “Because exclusion is done when you click on a deck, the counts you see on the deck list will differ from the ones you see when you click on a deck.” This indicates to me, that the “to review” quantity is created when I click on the deck.
In my case, I am in the middle of studying, and the “to review” count goes 48, 47, 46, 45, 44, 0, 0, 0

It’s a sudden zeroing of the “to review” count. This doesn’t seem to be a burying problem. Other ideas?

Just a thought… see if “check database” indicates any corruption.

Thank you, Rod, for a good suggestion. I did a Check Database, and all was well - no corruption. It did a little optimization, but that was it. I hadn’t done my studying for the day so I started. All was well until the “to review” number got to 59. Then after the next card it went down to 0. So I missed out on reviewing 59 cards. Bummer!
Checking the database for possible corruption was definitely worth a try. Thanks for the suggestion.

Please note the second link I posted applies to the v3 scheduler, which you are not using. The older scheduler buried as you reviewed, leading to jumps in due counts.

The v3 scheduler?? I downloaded the latest and greatest version a couple of weeks ago, and that is when I started noticing this problem. Is there a newer version of anki available?

You can activate the v3 scheduler in preferences.

1 Like

Thank you! I activated the v3 scheduler before my study session today, and I’m a happy camper! Before I actually entered my deck, it said “to review” = 79 + 63. When I got into the session the “to review” was set at 79. So it looks like the added number is the number of buried cards.

Thank you for your help. There were no sudden drops to 0 in this session.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.