Crazy Review Numbers on 2.1.47

About 5 cards from finishing my reviews, my learning number shot up to:

Nothing crashed or stopped me from finishing my reviews, but this is something I have never experienced before. The only thing else is that on my deck, from the overview page, it says 4 reviews:

but when I click into the deck, it shows 3:

I’m not sure if this part is related.

I suspect it’s related to undo or redo - the count went below zero and wrapped around. Did you use the redo action at all during the session? Or just undo? Do you remember what non-review actions if any you took prior to the undo/redo? I’m wondering how I might reproduce this.

1 Like

Thanks for getting back to me on this. I know for a fact I did not redo, but I did undo and edit a card. I can’t say this with absolute certainty, but I think it happened after I edited a card.

Thanks for elaborating, I’ll see if I can figure out how to reproduce this.

1 Like

It’s the same with me. I didn’t use redo! It counted down to 0, but I saw in the browser, that there will be more cards in learning and suddenly it changed back to 36 after this long number.

1 Like

I collected new information:

In my example there were 2 remaining cards in the learning pile from yesterday. Then it appeared a card, which I had wrong 20 min ago, but the counter didn’t change and stayed at 2. After I answered this card the counter went to 1.
To reproduce the huge number I think I was too slowly this time, because I wrote the steps here in between.

1 Like

Update: The exact same issue is also happening on AnkiMobile (iOS app). No editing, no redoing, no undoing, but just like the other 3-4 times it has happened so far, it was very close to the end of my reviews.

No editing/undoing through the entire session? If so, that is helpful to know, as it narrows down the possibilities considerably.

Yes, I never edit on AnkiMobile. It happened again on my reviews (on AnkiMobile) today. Again, no editing/undo/redo’ing and within the last 6 cards of my revieiws.

Please let me know how the latest release candidate goes - once this has been confirmed to fix the issue, an AnkiMobile update will follow:

The update changed it: It now doesn’t show this freaky high number, but just 0. It’s still the same problem, that the counter doesn’t get +1, when a card appears after a certain time, which you had wrong. So at the end of the session, there are cards left, but the counter says there aren’t. If you synchronize during review, you can see the counter update itself.

It would be great if you could narrow this down into a set of steps I can take to reproduce the issue. I was not able to reproduce the issue earlier, so I had to guess at what the problem might be, and it seems my guess has not fixed it.

I suppose it’s fixed with .49! Thanks! :slight_smile:

I also got this, no edits/undos/redos. Happened as soon as I finished my last review card, but it wasn’t my last card yet.Screen Shot 2021-11-08 at 3.44.52 PM

As the poster above mentioned, this is fixed in the 2.1.49 release.