Typing accents in macOS

I would like to be able to type accents when entering French vocabulary words. In macOS, this has been easy for a long time. Hold down the letter key, a bar pulls up with numbered accent options, select the option, and the accented character appears. When I do this in Anki, I get the letter followed by the same letter with an accent. So when I want é, I get instead eé. This means I have to go back and delete the unaccented e. Is there a workaround or does this need to be fixed by the programmers?

1 Like

This sounds like a bug in the toolkit Anki uses (not in Anki itself). Maybe you’ll have more luck with the other version, ie. if you are currently using Qt6, try Qt5, or vice-versa.

This is worth a try, for sure, but how can I do this? Trash the previous version and start over? In other words, I don’t know how to get to a place where I could select a different version.

You should uninstall the currently installed version, then go to https://apps.ankiweb.net/ and select the appropriate version from there. Note that, if you are using a computer with an Apple Silicon CPU, I’m afraid there is a single version of Qt available so you can’t switch the Qt5. Otherwise, just pick the other Qt version to the one you have installed in the Mac section of the Download paragraph.

Please see Adding/Editing - Anki Manual

A workaround / another option is to use the ‘dead key’ method. see: Enter characters with accent marks on Mac

This is the method I use, which is actually a lot faster for me. Basically, you hit option-{deadkey} to indicate the accent you want, and then type the letter that receives it.

Which deadkey you use depends on your keyboard layout, but the built-in keyboard viewer can show you what they are. I switched my keyboard layout from “U.S.” to “ABC - Extended” and I can use “option-6 c” to produce ĉ for example (typing in English remains the same in this layout on my MacBook pro)

Thanks for this, Davo. Very helpful.



1 Like