Trouble with importing .csv file to make cards with long texts


I’m new to Anki, so I hope that it’s not something obvious that i missed.
I tried to follow a tutorial on how to import cards into a deck through a .csv spreadsheet, with the basic Front/back card format, but, probably due to the fact that I’m trying to make a fairly long body of text fit into it, when I import the .csv file the two fields get mixed together and a big part of the second one gets cut.

This is the result:

I tried to do the same thing with just a couple of words for each field and that worked fine, and I also tried to add a card manually to a deck and there were no problems either, so I’m assuming that the problem lies in how I’m approaching the compilation of the .csv file.
Is there any limit on the characters you’re allowed to use in the spreadsheet for it to be used in the basic format?

Thanks for your answers!


You need to figure it out by yourself but pay attention to Field delimiter and string delimiter as you save csv. If you put inside spreadsheet cell the same sign as you use for a separator Anki will be confused.

In LibreOffice Calc there are options for it:

Also check if “Allow HTML in fields” in Anki import options makes a difference.


Thanks a lot, the problema was the field delimiter indeed.
I changed it in the region settings of my pc from “,” to “;” and used that to separate the data in the two columns.