Synchronisation Issue

Updated the latest Anki Update. Now if I add a new Card and synchronise it this occurs.

I tried to synchronise it from the Desktop Version and then download it to my IPad and my IPhone but it didn’t work. Restructured the data base multiple times. I hope you can help me. Thank you so much.

Tried a couple more things. I figured out that I only can add new cards from my PC. Then I can synchronise it to all of my devices and everything works fine. If I add a new card from my IPhone or IPad this occurs

Followed by this

Hope that someone can help me. Thanks a lot.

Okay buddy, this happened to me quite a few times. Don’t worry about it at all. The solution to this problem to to click either “ upload to web” or “ download from web”
Say for example if you want to keep the cards of your phone, click “ upload to web” in your phone and then from your laptop click “ download from web”.

(Note: you will loss your progress made in one side in this process, for instance let’s say you’ve reviewed 10 cards from your laptop and you choose to “upload to web” from your phone, then Anki will forget the reviews you did in your laptop and you have to do it again, so careful about the options, any progress made in only one side (which is not synced) before that, will be lost :frowning:
Hope that will fix this problem :smile:

Thanks for your answer. Unfortunately, I have also tried this more than once. Uploaded it and also Downloaded it and synced it afterwards. I also tried to use my old Backups but nothing helped :frowning:

Please try the following steps:

  • Enable the v3 scheduler in the review preferences (The Anki v3 scheduler - Frequently Asked Questions)
  • Use the Check Database action in the preferences to fix any errors
  • Force a one-way sync in the preferences, and choose Upload on the next sync. Afterwards, please Download on your other devices.

Does that resolve your problem?

1 Like

Worked instantly. Thank you so much!

I tried the dae solution with enabling the v3 scheduler, checking the database, and forcing a full one-way upload sync. After that I added a card and got the same error: “Error - Please use the Check Database function, then sync again. If problems persist, please force a full sync in the preferences screen.”

I tried more than this today, including re-installing Anki mobile on my iPhone. The problem seems to lie with adding a card only. The review functionality seems to work.

I tried ordinary upload, ordinary download, full upload, and full download. Nothing resolves the issue.

One last tidbit: I can add a card in the MacOS version of Anki and upload it, and when I synchronize with the iOS version, no error. It seems to be specifically creating new Anki cards on iOS version.

1 Like

Did you also used the new image occlusion feature?

I’ve been able to reproduce it - when you open the add screen, an image occlusion notetype is added if it’s missing from your collection, and it’s missing a flag that should be there to make it sync properly. I’ll make sure this is fixed in the next update.

In the mean time, you should be able to resolve the problem by opening the add screen once to ensure the notetype is added, then sync and choose upload. That will send the change to AnkiWeb correctly, and provided you download on your other devices, that should be the end of it.

1 Like

You guys are good. The workaround seems to have worked. I will document the steps in case anyone else needs them until the bug gets patched.

  1. Click on a deck
  2. Click add
  3. Click note type
  4. Confirm image occlusion listed.
  5. Back
  6. Cancel
  7. Decks
  8. Synchronize => error message
  9. Synchronize => upload
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.