Help - can’t sync between ankiweb and devices

Hi everyone, I’m facing that Anki doesn’t allow me to sync as it says in the pictures below. I’m also trying to sync on my desktop but it has the same conflicts.

  1. If I press on download from Ankiweb, after I see couple cards, the issue appears again
  2. If I choose upload to Ankiweb, it doesn’t allow me to do as it stops me at ~13mb of data

Kindly help, I’m on urge on upcoming exams, without it, my plan would be destroyed. Thank you !

Please go into the preferences and tap on Check Database. What does it say, and does it help?

1 Like

Thank you, Dae

I Checked the data base and here is what it told. I tried but it doesn’t help :frowning:

If it’s AnkiMobile you’re having trouble with, please use the Check Database feature inside its preferences screen instead of your computer.

It said the same thing, Dae.
Whenever I downloaded the deck from ankiweb and I see couple cards, it tells the decks conflict between the my devices and ankiweb. I think something’s wrong with the system

After using check DB on one of your devices, if you then try to upload, do you still get the failure? If so, it seems to imply network trouble. While the issue may clear up on its own, you could try syncing via your phone’s hotspot, or on a different wifi network to see if that works around it for now.

Yeah, changed my hotspot and a different wifi network; and it shows the same error. I think I will wait for couple days for the issue fixes on its own. Thank you so much for your help, Dae

Hi Dae, it’s me again
Sorry for being annoyed, but do you have any idea what’s going on with the Ankimobile relating to the issue I’m facing?

I’m using the iOS app 2.0.59. Yesterday, I was able to sync with Ankiweb by using my desktop, but the issue with my iOS devices remain the same. I use two iPhones with different Anki versions and it shows the same issue.

I checked the database, it says: the DB was optimized and rebuilt, but then I tried to sync, nothing Changed. When I tried to sync, it stops at 13.2 mb uploaded and said: sync failed, the upload corrupt and something wrong with the internet connection, but even when I tried to change the wifi, or using hotspot, it still doesn’t work

I noticed both your mobile and desktop versions are quite a few years old now, so it might be worth updating to the latest desktop and mobile versions to see if that helps.

yeah, thank you Dae.
The issue is fixed now by the latest update (unfortunately my old iphone with ios 10 unable to do so). Have no idea why it happens as it still worked well couple days ago.

Thank you so much for your support
Have a good day

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.