Anki Forums

Problem Syncing/ error when downloading from AnkiWeb

Using the desktop app I tried to sync after a review session and an error message claimed the changes were too great to be synced and I needed to either upload the deck on the PC or to download from AnkiWeb. That seemed odd since I had done nothing but review today and had already successfully synced earlier so I decided to open AnkiWeb and see how my deck was over there. Since it looked fine (just as it was before the latest review session) I concluded some files on the PC must have corrupted or something so I tried to download from AnkiWeb. The download took more than I expected and at the end I got this:

Captura de tela 2021-09-22 183648

Help? I already tried checking database, restarting the conputer and nothing, every time I try to sync I get the message the decks are too different and trying to download the deck from Ankiweb results in the error above. It was working fine just earlier today so I don’t know what went wrong, I didn’t add any card or anything, just doing my standard review session.

I’ve been having the exact same problem and it started the same way. Between desktop and ankidroid, with no particular changes, forced a full upload and I’ve been having this same problem. I believe it’s also related to ankidroid saying cannot download because of SD card issues despite not having an SD card.

I’ve tried exporting the desktop deck and importing directly from USB on ankidroid, OR exporting the ankidroid deck and importing to desktop, but neither of these work. I’m also having the same issue with an entirely separate profile/deck.

It really does seem like a recent update broke some specific part being able to sync some decks between ankidroid on android and anki desktop.

The first error looks like it may be temporary network problems, and it may be worth checking for packet loss: Syncing failed: Connection timed out errors when syncing - Frequently Asked Questions

There’s an issue over on the AnkiDroid tracker tracking the SD card error message: AnkiDroid Sync Error · Issue #9540 · ankidroid/Anki-Android · GitHub

Thanks Dae. I Followed that link I used the program indicated and, indeed, if I understood the program correctly it does seem I have an above 0% data loss at some point. As high as 8% in multiple hosts (not sure how high that is). If I understood right I should just wait for a while and see if the problem goes away. That sucks but I hope it is that simple.

Still, what caused the two decks to become so different that a simple sync is not enough and I need to download or upload the whole deck to match it? The data loss confusing the software even though there shouldn’t be any modifications?

A network error shouldn’t be able to trigger a full sync - if it does, that’s a bug. Are you still experiencing problems when uploading/downloading? If so, do you have access to a different network to try on? Please also follow the steps on When problems occur - Frequently Asked Questions

Yeah, the network problem is not getting any better, tried my mobile network and still no dice, I haven’t been able to download from the AnkiWeb at all. I haven’t tried uploading because I fear there is something wrong with the local files (since the full sync is triggering) so I don’t want to ruin the AnkiWeb files, as they seem to be fine.

I have followed all these steps before posting here. Except for the Video Driver one since it is neither a crash not a display bug, so I figured it couldn’t be related.

You don’t appear to be using the latest Anki version - did you try updating first?

Ah, yes, I updated when I first got the error. It was a quite old version before, though, forgot to mention, but it is updated now. It is ⁨2.1.44 which I understand to be the stable version? Should I try 2.1.48 and see if it work?

I was posting in that github thread as well. But as of this morning around 10am the issue spontaneously fixed itself for me. Good luck.

It seems it fixed for me as well! The network problem, I mean. It downloaded the deck much quicker and without any issues. It seems to be properly synchronized now.

It still asked for the full sync without any major alterations so that is still weird, but hopefully it won’t happen again.

No changes were made to AnkiWeb this morning, so it sounds like this was a network issue that got cleared up.