Sync of learning progress not working anymore

Hello,

Since today the sync of my learning progress in Anki is suddenly not working anymore between my two phones.
The one device is an Iphone, the other one an Android device. The problem is the Android device which is, not properly synchronizing the learning progress anymore. I have already tried anything:
Deleting the cache, uninstalling the whole app including the deletion of remaining files, installing Anki into a different directory on the phone, checking media, checking database, forcing synchronization (one-way synchronization). Nothing seems to work…

Has anyone got an idea how to resolve this issue?

Thanks in Advance!

best regards

Could you please describe how you perform a sync, and how do you ensure it hasn’t worked (ie. what elements are different from what you expected)?

I am basically just checking the learning progress, that is I am checking the numbers which are shown on the right side next to the name of the (sub-)deck in blue, red and green. Synchronization between AnkiDesktop, Anki-Iphone and AnkiWeb still works decent, but between AnkiDroid and the former it’s not working anymore.

To start the sync I am just clicking on the arrow circle icon on the top right corner.

Ah, this makes me think that you have different schedulers. IIRC, AnkiDroid doesn’t support (yet) the v3 scheduler, so the syncing is fine, but then AnkiDroid might not agree with other clients on what is due or not. This, in itself, is not an issue. Reviewing these on AnkiDroid and then syncing won’t cause an issue on other clients, and simply ignoring these over due cards won’t cause problems either. If, on the other hand, you still want all clients to agree, I think there is no other way than downgrading back to the v2 scheduler, which can be done in Tools > Preferences > Scheduling > V3 Scheduler.

I have disabled the new (v3) scheduler in the AnkiDroid App, however the problem is consisting… (Desktop and Iphone App do still use the old scheduler [checkbox is diabled]). It’s confusing. I didn’t change anything at all this week, a few days ago it was still working…

Thanks in Advance!

If you have the legacy timezone setting enabled in the preferences, turning it off may help.