Slow sync with excessive files


I have been trying all evening to sync my desktop anki with webanki to so I can use the mobile app which I just purchased. However, I can’t seem to get my desktop decks to sync. I have only around 500 cards on desktop, but I have tried many times to sync and the progress log is keep adding tens of thousands of files that aren’t there anymore. I believe the problem may be due to the following:

The first time I tried to sync, I had a lot of medical decks I don’t need right now (I used them to become familiar with anki before school started). Syncing was taking a long time and I think it ended in a sync error (I may have aborted the sync before this - sorry, I can’t remember, I’ve tried so many solutions on my own I am getting mixed up). I then deleted (cog wheel → delete) the decks I don’t want to sync hoping to speed up the process and then tried to sync again but forgot to close and then re-open anki. So I wonder if data from these deleted decks in still being uploaded.

Another weird thing is that my webanki looks just like my desktop anki (including with correct new and due cards) but I can’t seem to get syncing to work. Even with forced 1-way sync, I seem to upload thousands of files to webanki, or download thousands of files from webanki. I also don’t recall seeing the popup box (that appears during forced synch) the first time I tried to sync. I have looked on youtube for solutions and have read the tutorials, but I can’t find a fix. My desktop anki (downloaded 3 weeks ago) and mobile app (downloaded today) are both up to date. I have tried turning off autosync, forcing syncs (to and from ankiweb) and loading the deck exported file itself.

I am letting desktop to webanki try to sync overnight. I will update tomorrow with an error code if it is not successful, but are there any ideas how to fix this in the meanwhile? Thank you and sorry for the long explanation but I wanted to explain how I tried to fix it so any helpers know what I already tried.

The media files are probably still there. Use Tools >Check Media to delete them then sync again.


This worked! Thank you very much for your help.