Scheduler Not Updating Card Timing

Hey everyone,

I’d really like some help because I’m super frustrated. As you can see below, the timing of my cards is completely off with the good and easy options being months in advance even though I only recently unsuspended this card.

I made sure to close Anki (multiple times), reverted back to the default scheduling setting, clicked “save to all subsets” in the options menu, and clicked “Forget” for all the unsuspended cards, and nothing has worked. Forgetting the cards worked intermittently in the recent past but it doesn’t work every time. Not sure what’s going on. Any help would be greatly appreciated!!

See Due times after a break - Frequently Asked Questions.
However, Forget should work as it moves the card to the New queue again. Maybe you didn’t select all cards when performing the action?


I forgot every unsuspended card. And it’s definitely not working because when I do this, some cards reappear with their old scheduled timing, so it’s like there’s a mix of cards with both old and new scheduling even though all the cards have been forgotten.
And it’s just odd because many of these cards are completely new cards that I’m studying, not old cards that I’m relearning so I wonder why the timing looks like this.

Maybe you’ve imported these cards from someone who’d mistakenly exported them with scheduling information?

Still, I can’t see why Forget would not work. When you encounter such a card, open the browser and perform Forget, doesn’t it become a new card immediately?

1 Like

Hi Rumo,

I see now that the forget feature was working just fine, but I didn’t realize I also needed to adjust the intervals under the New Cards section to correctly adjust the timing. Thanks for the help!