Anki Forums

Related cards, both new and review, not being buried

Hello,

I recently upgraded to the new scheduler and now have a problem with cards, both new and review, not being buried. I assume I’m overlooking something in my configuration and/or don’t understand the behavior of the new scheduler. The problem seems to be consistent on both the desktop and mobile versions, but I’ve been primarily using the desktop version for testing.

A little more specifically, I don’t understand why, as shown below, the related cards — Card 2 when they’re both new, and Card 1 when they’re both up for review — aren’t buried after the review of their respective sibling.

Thanks in advance for the help.

Options for Test - New cards

Options for Test - Reviews

Options for Test - Lapses

I created a new card in the Test deck, a basic card with reversed. I then went into the Test deck to study. Card 1 was marked as “easy,” thus hopping over the learning queue, if I understand correctly. Card 2 was marked as “good,” then “good” again. I then rescheduled both cards to be due today and reviewed them again, both being marked as “good.”

Card 1’s information

Card 2’s information

Debug information:

Anki 2.1.44 (b2b3275f) Python 3.8.1 Qt 5.15.1 PyQt 5.15.1
Platform: Linux
Flags: frz=True ao=False sv=2
Add-ons, last update check: 2021-07-25 12:25:55


===Add-ons (active)===
(add-on provided name [Add-on folder, installed at, version, is config changed])


===IDs of active AnkiWeb add-ons===


===Add-ons (inactive)===
(add-on provided name [Add-on folder, installed at, version, is config changed])

Your review history for those cards does seem to imply they weren’t buried, assuming you’re not using some add-on that automatically unburies or otherwise influences the scheduling. Please note that you have enabled the v3 scheduler in AnkiMobile, but the 2.1.44 version you are using on your computer does not support it yet - so you’ll actually be using v2 on the computer, and v3 in AnkiMobile. If this is a bug, I would expect it to work on one scheduler but not the other.

Could you please try updating to the latest 2.1.45 release candidate, and then see if you can reproduce the issue? I gave it a quick test, but could not - only one card was included, with the other sibling being buried up-front. https://betas.ankiweb.net/

Thanks for the help with troubleshooting. Note that I don’t have any add-ons installed.

While I tested yesterday, both the latest 2.1.45 release candidate and a clean profile with 2.1.44 worked as expected while I still had problems with my old profile. One time during my testing I was able to get burying to work as expected in the desktop client, but I “lost it” and wasn’t able to recreate the solution. My hypothesis was that it had something to do with synchronizing while V3 was activated on the mobile version and then using the desktop afterward. I had made a plan last night to test all of the different pathways (card creation on mobile with/without V3, synchronization with/without V3 to desktop, study on desktop, etc.), but today, however, cards are being buried as expected in my old profile.

We can consider this fixed for now, though I unfortunately can’t explain what the solution was.

If you find it happens again in 2.1.45+ and spot a pattern, please let me know.

@dae, I’m on ⁨Anki Desktop for Mac 2.1.47, and my related reviews are also not being buried.

Two related cards:
Card A: This was shown first earlier today. Pic shows the card info showing latest review = 9/15/21


Card B: This card was shown after Card A despite having the same Note ID

Deck options:

Debug info:

Anki 2.1.47 (dc156f34) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Mac 10.16
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2021-09-14 17:32:29

===Add-ons (active)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
AMBOSS add-on ['0amboss_addon', 2021-07-13T17:21, 'None', '']
Additional Card Fields Fork for 21 ['744725736', 2020-09-20T06:50, 'None', mod]
Anki Habitica for 21 ['1758045507', 2021-05-15T07:15, 'None', mod]
Anki Simulator ['anki_simulator', 2020-03-28T14:47, 'None', '']
Anki Zoom ['538879081', 2020-04-03T19:20, 'v1.1.3', '']
AnkiConnect ['2055492159', 2021-07-13T19:59, 'None', '']
Batch Editing ['291119185', 2019-06-02T13:47, 'None', '']
Card Info During Review ['2179254157', 2021-02-05T04:22, 'None', '']
Clickable Tags v20 Anki 2120 support ['1739176371', 2020-03-13T09:25, 'None', '']
Cloze Overlapper ['cloze_overlapper', 2019-02-01T06:37, 'None', '']
Customize Keyboard Shortcuts ['24411424', 2021-07-06T23:28, 'None', mod]
External Note Editor for the Browser ['1996266159', 2020-03-31T15:59, 'None', '']
Fastbar- with nightmode support ['46611790', 2021-08-22T15:33, 'None', '']
High Yield Tags ['1918380616', 2021-08-06T19:48, 'None', '']
Highlight Search Results in the Browser ['225180905', 2021-03-10T11:06, 'None', '']
Hint Hotkeys ['1844908621', 2019-11-17T05:42, 'None', '']
Image Occlusion Enhanced for Anki 21 alpha ['1374772155', 2020-04-27T21:21, 'None', '']
ImageResizer ['1214357311', 2021-04-10T11:15, 'None', '']
Learning Step and Review Interval Retention ['1949865265', 2020-12-28T16:40, 'None', '']
Load Balanced Scheduler ['208879074', 2019-12-17T14:20, 'None', '']
More Decks Stats and Time Left ['1556734708', 2021-01-27T03:09, 'None', mod]
Paste Images As WebP ['1151815987', 2021-09-03T07:10, 'None', mod]
Progress Graphs and Stats for Learned and Matured Cards ['266436365', 2020-03-29T01:26, 'None', '']
Resize images in editor ['1103084694', 2021-07-19T01:35, 'None', mod]
Review Heatmap ['review_heatmap', 2018-10-28T17:06, 'None', '']
Search Everywhere - Ctrl+F Find ['search_everywhere', 2020-03-31T15:13, 'None', '']
Special Fields ['1102281552', 2021-06-20T16:27, 'None', mod]
Speed Focus Mode auto-alert auto-reveal auto-fail ['1046608507', 2019-12-17T13:44, 'None', '']
Straight Reward ['957961234', 2021-01-11T06:37, 'None', '']
Syllabus - Anki Statistics and Export by Tag and Deck ['668156440', 2020-01-16T15:21, 'None', mod]
Symbols ['1461102936', 2019-12-17T14:01, 'None', mod]
The KING of Button Add-ons ['374005964', 2020-04-17T17:33, 'None', '']
True Retention by Card Maturity ['923360400', 2017-08-29T14:00, 'None', '']
rebuild allempty all filtered decks enhanced fork ['104518886', 2021-07-05T04:12, 'None', mod]

===IDs of active AnkiWeb add-ons===
104518886 1046608507 1102281552 1103084694 1151815987 1214357311 1374772155 1461102936 1556734708 1739176371 1758045507 1844908621 1918380616 1949865265 1996266159 2055492159 208879074 2179254157 225180905 24411424 266436365 291119185 374005964 46611790 538879081 668156440 744725736 923360400 957961234

===Add-ons (inactive)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
Leaderboard ['41708974', 2021-06-16T14:40, 'None', mod]

Burying settings are taken from the specific subdeck cards are in, not the parent deck, and learning cards are not eligible for burying in the v2 scheduler.

https://faqs.ankiweb.net/the-2021-scheduler.html#burying

@dae I’m using Anki desktop windows Version ⁨2.1.47, all my related reviews, learning, and new cards are not being buried on my main deck. The problem was also in previous versions so I tried updating to Version ⁨2.1.47 and turned on the v3 scheduler but the problem isn’t solved still. However, this problem only happens with my existing decks but if I create a new deck and add cloze cards they are buried properly. This problem is on both the desktop and the android versions.
Thanks in advance for helping.

Options for the decks that have the issue:





Debug info:

Anki 2.1.47 (dc156f34) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Windows 10
Flags: frz=True ao=True sv=3
Add-ons, last update check: 2021-09-17 09:48:25


===Add-ons (active)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
AMBOSS Official  Medical School Step  Shelf Study Resource ['1044112126', 2021-07-26T13:47, 'None', '']
Advanced Browser ['874215009', 2021-07-23T00:14, 'None', '']
Button Colours Good Again ['2494384865', 2021-04-06T17:57, 'None', '']
Card Info During Review ['2179254157', 2021-02-05T13:22, 'None', '']
Clickable Tags v20 Anki 2120 support ['1739176371', 2020-03-13T17:25, 'None', '']
Custom Background Image and Gear Icon ['1210908941', 2021-08-20T04:20, 'None', mod]
Edit Field During Review Cloze ['385888438', 2021-07-31T08:57, '6.7', mod]
Hierarchical Tags 2 ['594329229', 2021-03-07T05:25, 'None', '']
Image Occlusion Enhanced for Anki 21 alpha ['1374772155', 2020-04-28T05:21, 'None', '']
Picmonic Anki Add-On ['40737180', 2021-07-28T01:27, 'None', mod]
ReviewHeatmap ['723520343', 2019-08-03T18:14, 'None', '']
Special Fields ['1102281552', 2021-06-21T00:27, 'None', '']
Speed Focus Mode auto-alert auto-reveal auto-fail ['1046608507', 2019-06-02T12:11, 'None', '']
Symbols As You Type ['2040501954', 2021-03-22T05:17, 'None', '']
Symbols ['1461102936', 2019-04-18T23:21, 'None', '']
True Retention ['613684242', 2017-11-19T23:43, 'None', '']

===IDs of active AnkiWeb add-ons===
1044112126 1046608507 1102281552 1210908941 1374772155 1461102936 1739176371 2040501954 2179254157 2494384865 385888438 40737180 594329229 613684242 723520343 874215009

===Add-ons (inactive)===
(add-on provided name [Add-on folder, installed at, version, is config changed])

You have a separate “Anatomy” deck preset that has burying disabled.

@dae yes but I am not using it for the main deck, could it be causing this problem?

If by “main deck” you mean “AnKing”, various subdecks of it are using that preset. If you believe a card has not been buried when it should be, please check the settings of the deck that particular card resides in, and please make sure it’s not a learning card with a delay below 1 day.