Related cards are shown in wrong order

I have imported a text file into note type that has several cards. I have created a separate options group for it and chose “show new cards in order added” and disabled “bury related new cards”. But still, when I go to study the deck, it shows me the card1 of first note and then jumps to the card1 of the second note and then to the card1 of the next note.
I went to the browser to confirm the due numbers are correct and tried to manually reposition the cards and give each card a different due number (as shown in the attached image) and checked database, but Anki still shows me the first card of each note first.
Edit: I’ve just created another profile and updated to the new scheduler (hoping it is the solution) and created some cards with siblings but sadly the problem still persists.


I’m on Windows 10 and Anki version is:
Version ⁨2.1.43 (0fbae6bc)⁩
Python 3.8.6 Qt 5.14.2 PyQt 5.14.2

I’ve just remembered that this wasn’t the case before updating to the latest version. So, is this an intended behavior or is it a bug?
@dae please help.

The behaviour has not changed any time recently; you may have been using an add-on in the past. When burying is off, siblings are dropped from the queue so they are still spaced apart.

Oh, it might have been one of the dozen add-ons I had but didn’t get updates…

Any plans to add an option to disable this behavior for individual decks?

It may come in a future update

1 Like

I’ve just run into the opposite problem:
When selecting “New cards in random order” and burying is On, Anki is showing me the first card of each note first.
It would be great if the order of siblings can also be randomized.

Both cases should be covered by the v3 scheduler.

1 Like