Can I stop the burying not related cards?

After switching to a new schedule the program became automatically burying cards.

Assuming you’re using v3 scheduler, I suppose you have unchecked this:

If that’s not the problem, could you elaborate / post an example of the issue?

This option is disabled
Most often this happens after pressing Hint.

If burying is disabled, they won’t be buried, but the order they appear in will depend on your settings in the display order section.

Ok sorry the problem was caused by another program.