Problems with input field and add-on

Soooo dear community it is a little bit difficult but i tried to create a own deck for vocabulary.
I learned the Oxford 3000 before and now i would like to start the 2000 extra to the Oxford 5000.

I found a add-on with which i can automatically translate a list of words out of a text format to a anki deck. It get called “EasyVocab” ( So i translated the words and created a deck.

After i had the deck. I switched the front and back site so that i have to translate the english word to german and not on the opposed way.

I also would like to add a input field like it was in the deck of the Oxford 3000. So that i can also type in the words and get tipps where i spelled wrong.

So i though that i just can take some code from the Oxford 3000 and put it in the Oxford 5000 deck.
But it didn’t worked.

I destroyed the deck and though: “Ok i just creating me a new deck” and try again. But now always if i create a new deck with the add-on the changes of before are in the new created deck.
Also if I reinstall or delate the entire datas out of the folder and reinstall after that.

So my big questions are:

  1. How i can reset the add-on on his previous functions?
  2. How i can incorporate in the new deck a type in option/field?

Thanks for the help, dear community :heart:

I don’t think you destroyed anything, and you don’t have to make a new deck. It looks like you just miscopied/mispasted the text of that template.

It sounds like you made your changes directly on the templates that came with this add-on? You can usually get back to the original Note Type and templates by deleting and reinstalling the add-on Add-ons - Anki Manual.

It might create a 2nd Note Type with a similar name, but you can figure out which one is correct, use “Change Note Type” to shift your notes to that Browsing - Anki Manual (make sure you are in sync before you do that), and then delete the unused one. If that doesn’t work, you can try renaming the Note Type first (so the add-on installation doesn’t recognize it as already existing).

But in general –

  • If you want to roll-back changes and you’ve made them just now – Undo / Ctrl Z.
  • If you want to roll-back changes made longer ago than that – Restore from an automatic or manual backup Backups - Anki Manual .
    • [If you just want to grab one thing from a backup (like the text of these templates), you can minimize data loss by importing the backup into a brand new (temporary) profile, find what you’re looking for, copy/export it, and then delete that profile.]
  • If you want to copy a Note Type that you found – Rather than copying the text one piece at a time, just copy/clone the entire Note Type Adding/Editing - Anki Manual. Then you can make the edits to it that you want (makes too many/few cards, has too many/few fields, etc.) and change your notes to use that new Note Type Browsing - Anki Manual .

As for the original “type your answer” change you were trying to make – Field Replacements - Anki Manual .

1 Like

Thanks for your answer. I already delated all the decks and created new ons. Its ok. But i dont understand it, in the deck with the original type-function is no real text (just the stuff which you see in the second and third picture). There ist just two lines of text. Do i misunderstand there something. Maybe i just changing some stuff of the template what i mayby should dont do.

If i reinstall the add-on and delate the entire dates of the add-on before and than reinstall the changes are still there. I think i also have to delate the datas of the template, or?

Thank you for your help.

The last link I posted explains about “Field Replacements” and “Checking your Answer” templates. [The manual in German Anki Manual .] It doesn’t take a lot of text to make a card template, but you should make sure you understand how it works before you start making changes.

Did you try what I suggested?

If that doesn’t work, you can try renaming the Note Type first (so the add-on installation doesn’t recognize it as already existing).

So i tried to restore the old template but i came to late or to early while time traveling.

I think what you are saying is that you don’t have a backup from the right time that you can restore. :person_shrugging:t4:

Have you tried –

  1. Rename the Note Type
  2. Delete the add-on
  3. Restart Anki
  4. Install the add-on
  5. Restart Anki

Does the add-on re-create the original Note Type?

no the add-on dont re-create the original note type, i think so. I think i tried also to delate the note type.

So i went into the cardmanager tog a card opened the card preset. And there I changed the name of the note type, the only and one which was available . Than i did what you sat and also created a need deck with the add-on to test it. It didnt worked. It also didn’t worked with a brior existing deck. And i think i also wouldend anyway because i didn’t change there something. I just made changes in the new created deck i think so.

Maybe i just should completely safe the folder of anki. And reinstall anki in whole.

I know we’re dealing with a language barrier here, but your messages are not making much sense.

Reinstalling Anki isn’t necessary. The issues are in your collection, not the program. Do you want to delete your collection (cards, decks, etc.) too?

You made changes to the note types/card templates. That impacts every note that uses that type and all of the cards made from that template. It’s not limited to a specific deck.

From your screenshots, it looks like it was note types Basic (type in the answer)-b1232 and Prettify Vocabulary Card that you changed. Which one are you trying to fix?

Which language is your mother language? I mean reinstalling because i tried to recover the original template but it didn’t worked. Than i tried to renamed the the note type it didn’t worked, I reinstalled the add-on several times with delating the files of the add-on folder. It remaining two possibilities reinstall anki with safing all other important decks or delating some other files out of some other folders in the anki folder universe. :slight_smile:

I trying to fix this one:

It seems like the add-on that you’re using didn’t come with Prettify Vocabulary Card note type. You need to figure out where that note type came from (perhaps some of the links in your screenshot will help with that), and get a fresh version of it from that source.

So i tried to find the template for the plug-in on the GitHup site. But i didn’t found something. I also wrote the author of the plug-in. But its seeming that he is not that active anymore.
So it seams to me that i would be a more easy way to create a new account on my mac and install there a fresh version of anki.

You can create an additional profile in this same installation of Anki – Profiles - Anki Manual (another account on another computer isn’t necessary). It will have none of the decks, cards, notes, types, and templates you have now. That’s a great way to get a “clean”/unmodified look at something.

That may be helpful here, but not until you figure out what shared deck you got this template from! It didn’t come with an install of Anki, you downloaded it from somewhere – I expect at one of those links in the template, but I’m not going to research that for you.

It came from the plug in that i installed. Why it not created new on a reinstallation ? I don’t know. I created a new user profile on my mac. Installed there anki, installed the plug-in and set up a new deck with the plug-in. There i copied the template, and past it on the deck which i used to learn.

There were simpler ways to do that, but I’m glad you found what you were looking for.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.