On some cards, Anki is showing me the answer first

I’ve read the suggestions given to other member with the same or similar problem. Under “Tools-Manage Note Types”, I see that I have 337 notes with this type: Basic-33f41. And I have 1499 notes with this card type: Basic-4cdbb. And 0 notes with any other card type. Most of the time, it works as it should. Just recently on some cards, it’s showing me the answer first. When I go in to edit the card, a blank “add reverse” drop down option is open. If I close it, exit that card, then go back in, it’s open again. I’m using Anki for language study, and, for my purposes and arrangement, I never need to see the reverse side of the card except to see what the answer is. Please advise. Thanks for your help.

It sounds like one of your “Basic-…” note types is flipped. If you post the front/back templates for each of them, it might be easier to help you figure out which one.

If you want to figure it out on your own, it will be the one where the “front” template has a Field Replacement for whatever you want on the back of the card. Then you just can often (if your template is very simple), just click the “Flip” button in the template editor to put it right.

I think what you mean by this is that your note type is really a (renamed) “Basic (optional reversed card)” – so it has an “Add Reverse” field available for you. Is this what you mean by closing the “drop down option” in the note editor (ignore the weird field names)?
image

That’s not a problem – but there are a few ways to make it stop happening if it is an annoyance. Which of these sounds like what you want to try?

  • Switch to a different note type that doesn’t have that field
  • Set that field to be collapsed by default in this note type
  • Modify this note type so it no longer has that field

Thanks for such a quick response.
Here’s a screenshot of the answer being English when it’s suppose to be the question
image.png

And here’s a screenshot of the card type with the ADD REVERSE option open, but blank.
image.png

And here’s a screenshot of the ADD REVERSE option closed.After I close the card, then open it again. Voila! the ADD REVERSE window opens up again!

To answer your question, I think I like option 2 because it sounds easier.

  • Set that field to be collapsed by default in this note type.
    But I’m not an expert on this!

I look forward to getting your recommendation.
Thank you.
Timothy

The 2 things have 2 separate fixes –

For the front/back issue –
You’re going to need to edit your card templates (the instructions that Anki uses to create a card from your notes) in the ways that I described above. You can click “Cards…” at the top of your note editor to get there. You can post your templates here if you want specific instructions. Or else, watch the “Switching Card Order” video (old interface, but all the buttons are the same).

For the field issue –
If you go into Manage Note Types > Fields (Adding/Editing - Anki Manual), you can set that field to “collapse by default”

I’ve already follow your second suggestion and switched to automatically collapse the reverse side. As for the first issue, here’s my front card template screenshot, with the back card following immediately. Thanks again for your help.
image.png

As you will see, the front and back previews are identical.
image.png

Here’s the back template with the back preview.
image.png

Thanks again for your help

Timothy

My instructions above should work just fine for you. You can see that your front template only has one thing on it – the contents of your “Back” field.

Click “Flip” to fix that.

That’s not a typical “preview” – it’s an error message telling you that the way you have things configured right now, this note won’t create a card, because there’s nothing to put on the front of it.

Danika,

Timothy

1 Like