New scheduler and Custom Study Sessions

Since switching to the new scheduler, whenever I fail a card in a custom study session (e.g., “Review Forgotten Cards”), it instantly asks me the card again (the very next card or the one after that), which doesn’t really say much about whether I have relearned it. In the previous scheduler, failed cards were reshuffled into the study session deck, so I wouldn’t see it right away, which was much more effective (and more similar to regular studying). Is there any way for me to tell Anki to do this behavior with the new scheduler?


This looks like a bug. If you click on the options of the custom study session and change ‘repeat in … 0 minutes’ to 10 minutes, it should resolve the issue for now.

Thanks, I’ll try that. I also tried the v3 scheduler (original post was about v2 scheduler), and no matter what answer I chose, it always asks me the same card again in an infinite loop, so I have to disable v3 scheduler to review forgotten cards at all (tested on both Windows and Anki mobile). I also noticed that all answers in the attached screenshot say “end”. Perhaps it’s related?

It looks like AnkiMobile doesn’t expose the preview delay option at the moment - it can be adjusted using the desktop version. I tried to recreate the issue by creating a new custom study deck, but could not - is it possible you may have accidentally altered the setting in the past? Can you reproduce the issue after deleting the custom study deck and creating a new one?

While simply deleting and recreating the custom study deck didn’t fix it, your first suggestion of going to desktop version and changing the “repeat failed cards after” from 0 to 10 minutes did the trick with both the v2 and v3 scheduler :slight_smile: I don’t know how it became 0 but if this happens again I’ll be sure to check it out. Thank you so much!