New cards stay in "learning" status forever Please Help!

I have been using Anki desktop with Windows 10 and the AnkiMobile ios 2.0.86 for several years to study vocabulary. Both the ios app and the desktop version have been prompting me to update to the 2.1 scheduler for a while, but I have been ignoring it because everything has been working fine so far.

This morning the app told me that I needed to update to use it. I did a full sync upload to the Anki server, but then the upgrade button disappeared. Now when I am studying new cards they stay in the red “learning” status no matter how many times I click the green “good” button.

I tried updating the desktop version to 2.1.49 and the desktop version in doing the same thing. I tried updating to 2.1.51 Qt5 and it makes no difference. As far as I can tell the ios 2.0.86 is the latest version of the software.

I use Anki everyday to study 400 - 500 vocabulary cards. Not studying for just one day would make it really hard to catch up. I really don’t know what I will do if I can’t use Anki anymore. I can’t figure out how to fix this problem. Can I somehow revert back to the previous version that worked for me? I saved a backup before I tried updating.

Thanks for any help.

Try starting the program with add ons disabled.

1 Like

Hi. Thank you. I don’t think I am using any add ons, just the basic program, but I tried it anyway. It is still giving me the same issue.

Strange. Have you also tried the other steps in the FAQ (#4 and #5 in particular)?

If so, I would try to restart the program and import your backup again.

Btw, do you have the same problem in Ankiweb?

I checked the database and it had no problems and have also tried restarting my computer. I hadn’t tried Ankiweb before, but checking just now, yes the same problem is occurring there as well.

Can you please post a screenshoot of your deck options here?

On the other hand, if you create a new, “test” deck with some test cards, and use the standard deck options for that deck, do you still have the same problem?

The only thing I have changed for one of my decks is the new cards per day. Everything else is the standard deck options.

I tested creating a new deck with standard options and the same issue is affecting it as well.

How about if you create a new test profile? Same problem there?

Hi asparagus.

I created a test profile and some test cards and they worked like it should. So then I created a new profile and imported my backup file, but it has the same problem as before. So I guess the problem is with that file?

1 Like

The problem is you keep pressing the Hard button, which means ‘repeat the current step’ in the v2 scheduler. For learning to progress, you need to use either Good or Easy.


Thank you Dae.

I feel really stupid for such a simple thing to be the root of the problem. I have the display language of Anki set to the language I’m learning and to be honest I really wasn’t reading what the buttons said.

Maybe another unobservant person will get confused about the same thing and find this thread useful.

Thanks everybody for the assistance.

1 Like

I would agree with you, but in the past, if you said something was difficult, it would:

  1. see that you got it right and
  2. make you wait at least a little longer to see it again (after all you got it right!)

So even if you said it was difficult over and over, Anki would show it less and less and less…because again, you were getting it right, even though it was a bit tough

I am having the same issue. After updating, if you say something is difficult, it doesn’t count it as wrong. But it also doesn’t extend the time it takes for you to see it.

In fact, a bigger issue happens. All the cards that you rate as difficult go into and infinite loop. It says that you will see it in 6 minutes but it will cycle through them over and over again, never saying that you completed your deck.

There is something definitely wrong with rating something as “difficult”. Either this needs to be fixed, or the button needs to be removed

You can configure the way that button behaves with this setting:

Assuming you’re speaking about new cards, why is that a problem? I see it as normal behavior, if a new card keeps being difficult to you, Anki should repeat the current learning step (show the card again in a few minutes) instead of advance to the next learning step.