Negative number of words


Why does Anki go to a negative number of words when I study them? Anki was stopping to study at 0 before the update. And after the update, Anki became to go through the zero (-1, -2, -3, etc.).

Thanks in advance.

Can you please elaborate what you mean by that? A more detailed description or even screenshots would be helpful.


I start to learn the deck:
2020-08-30 09_07_41-Kirill - Anki

Must end here:
2020-08-30 09_11_59-Kirill - Anki

But no :slight_smile: :
2020-08-30 09_12_43-

2020-08-30 09_13_18-Kirill - Anki

It looks like a bug. The scheduling code is going to be reworked soon, which will hopefully address this as a side-effect.

Thanks. I’ll wait new version…


I notice another thing, the wrong card limit. I set the maximum review per day is 50 but Anki shows me ~35 per day. I believe these bugs are bound.
Now I use 2.1.35.
BTW, please say in what version will you plan to fix these bugs?

I suggest you check the limits of both parents and child decks and the burying options, as I’m not aware of a bug causing the behaviour you describe.

Today Anki has to show me 50 cards.

What does Anki? Anki shows me 50. 35 are as positive and then 15 are as negative cards. But I only see 35 cards at the display (only positive) and I don’t see the negative part at once. It’s kinda offset. today maybe 35 positive and 15 negatives, tomorrow maybe 33 positive and 17 negatives.

I don’t see any cases when I would set limits are negative. And Anki doesn’t allow me to do it. My daily limits are fine.

I demonstrated this bug early in this thread.

It’s behavior looks like a bug, you say the same too before:

BTW maybe it helps, I have these bugs in this main deck only. Other main decks have no children or have one or two. This deck has a tree, for example, the longest path of children: Languages::English::Words::Adjectives.
I have five Languages. As you maybe see this deck is very thick.

This situation began when I updated to 2.1.2x (I don’t remember exactly, IMO it was 2.1.26). These bugs were not here before I updated Anki.

Also, you say:

Please say in what version will you plan to try to fix these bugs?

Oh, I thought you were reporting a different issue, not the same one. A fix will come when I have a chance to rework the scheduling code; I am currently busy with other parts of Anki. If I recall correctly, this is caused by having daily limits set on the child decks with the v2 scheduler enabled, and if you increase the limits on the child decks, I suspect it will work around the problem.

To what extent do I need to raise the limit? Does the limit of child decks have to equal the limit of Languages deck? Is all children and child of the third line, etc?

Enough so that the parent is the one limiting the number of the cards, rather than the child decks. The deck options screen has an option to apply settings to all child decks at once.

I don’t understand. Let see an example:

Languages (Limit - ?; Cards - 0) - deck for group only.
 |------Words (Limit - ?; Cards - 0) - deck for group only.
 |         |-------Adj (Limit - 5; Cards - 10)
 |         |-------Noun (Limit - 10; Cards - 50)
 |------Idioms (Limit - 25; Cards - 100)

What limit I have to set to Languages and Words decks?

If you are using the V2 scheduler then the limit on the child decks is not being honored anyway. So you should just set the top deck to the total cards you wish to do that day, and all subdecks to a high limit like 1000.

Yes, I use V2 scheduler.
I kinda understand.
I.e. if will I have a child desks limit is less than the main desk the bug will be here?

If my memory serves me correctly, yes.

The same action do I need to do with new cards? Can this bug be there?
Just I have been disabling this function.

New cards are handled differently, so should not be affected by this issue.

As temporal solve it is fine.