"Media sync starting" stuck

Running 2.1.66 Qt6 Windows 10
All add-ons disabled, tried force quitting and restarting computer. Media sync works properly on other devices with the same account on the same WiFi. I did a media check and deleted unused media and emptied trash, as well as a database check. Nothing seemed to fix it.

Everytime I sync, it syncs the cards just fine and quickly, but the media sync never starts. It says:
“Media sync starting…”
then nothing for a few minutes
"Connection timed out. Please try again. If you see frequent timeouts, please try a different network connection.

Error details: "

I tried adding a .png screenshot of this in this post but it says “Sorry an error occurred”.

Edit: Occasionally, the media sync will start but it goes incredibly slow. It will take 5 minutes to upload 3 images, despite having very fast internet speeds.

Maybe some connection between you and AnkiWeb’s servers is currently being unreliable. As a temporary workaround, you could try increasing the timeout in the preferences screen, or try syncing with a different network provider (eg cellphone hotspot, or work wifi)

I tried syncing with a different network provider and the issue persists, only on this Windows instance. Ankidroid, ankimobile, and Mac Anki Desktop all function properly, even under the same network.

That is curious. Some ideas:

  • some sort of filtering on that machine, like antivirus/firewall software
  • a proxy or VPN being configured
  • a wifi card on the fritz

Not sure what happened but it started working! I didn’t change anything, might have been a weird internet thing

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.