Maybe a bug about synchronization in the latest steady version

Hi, I met a problem when I use the latest steady version ( 2.1.26). I found that after I updated my Anki desktop from 2.1.19 to 2.1.26, I cannot upload my new media files (mp3) and I cannot found them in my ankiWeb or ankiMobile. But after I reinstalled with 2.1.19, all these media files were uploaded successfully and I can also found them on my iPhone. So, I wonder whether it is a bug or it was caused by my wrong way of updating? Since I just downloaded the latest installation package and overwrote the old version.

Please return to the latest version, use the Tools>Check Media option, and then sync again. If you continue to experience problems, please let me know.

Hi. Thanks for your reply. I’ve tried your suggestion (return to the lateset version, check media option and sync) but the problem still existed. And the method that returning to the old version still works for me.

Did you confirm the media log said that the sync had completed?

I am not sure whether the way to open log file is buttoning the “check media” option. If so, I really haven’t found it showed the sync had completed. But after I have waited for minutes, I still cannot find those files on ankiWeb or ankiMobile. Since my files are small and I think I don’t need to wait for minutes, I think there would be some problems.

Check media is a different screen. If you tap on the sync button when a spinner is shown next to it, it will reveal more details about the syncing progress. You can also access the log in the preferences screen. If you see “media sync complete”, everything should have been transferred. After seeing that, if you find some files are missing in AnkiWeb, please let me know.

1 Like

Thanks for your patience. I finally found the reason is the proxy I was using. The problem on version 2.1.26 has been solved after I set my envrionment variables.

Glad to hear you were able to resolve the issue :slight_smile: