Make 1440 absolute?

I added some new cards last night around 10pm and did the first learn step. The interval for the second step is 1440, but those cards are up again the next morning at 7am, which is the “day starts” setting. Why is that interval not respected? How do I make 24 hours be 24 hours and not next morning?

Has no one else run into this before?

I think that is the behavior of the v2 scheduler. You can use the default (i.e. disabling the experimental scheduler).

I do not have the beta scheduler enabled

Ok. I just carried out a test. That is indeed true for the default scheduler. Dae commented this in a related post (>1400 steps are scheduled in days, not seconds, so all day-learning cards become due after the day cutoff):


Thanks. But wow, that is kind of shocking to just cut 24 hours down to 9 like that. Is there a fix for this? Can we disable the day-change awareness altogether?

Sleep is important for memory consolidation, so Anki is more concerned with the number of sleeps you’ve had than the exact number of hours delay. If you want to ensure you get at least 24 hours delay, you can pick a longer delay like 36 hours.