Anki Forums

Interval problem

anki keeps showing me these intervals.

Yesterday I tried to change some timing settings which I didn’t end up liking and then switched back to my old settings (the ones anking recommends). Since then it keeps showing me these settings. My settings are the same exact one’s as a friend and theirs is not having this glitch. please help becasue I am freaking out.

So far I have reinstalled anki and restarted my computer but neither have helped.

Screen Shot 2020-09-27 at 12.13.03 PM

It would help to have a screenshot of your settings, especially of the New Cards and Reviews tabs. Also, make sure that you are in the Options group of the deck that actually contains the cards and not of a parent deck for example.

If you change the learning steps while cards are in learning, the delays may be strangely until you either graduate the card or answer Again to reset it.

Thank you so so much for taking the time. I also just noticed this specific deck that is allowed 999 new cards is only showing me 20 new cards even though I just unsuspended a ton of cards.

Ohh I see that would make sense, so hopefully it just goes away on its own…

Your original screenshot shows exactly what is expected form these settings: New cards will have two learning steps, 14 minutes and one day (1440 minutes). If you press “Easy”, they will skip those and go straight to the “Easy interval” of 4 days. What is it that bothers you about this behaviour?

The new card limit is another matter. If there are enough, Anki should show more than 20. Maybe the deck is affected by another option group with a more restricitive setting or an add-on is interfering.

my impression of the “14 1440” was that it means the “again” will be for 14 minutes but “good” will be 1 day. Am I mistaken? I think you are saying that “14 1440” means good alone is 14 minutes for the first time and then 1 day the second time?

I would like to figure out a way where the first time I see new cards, they will be shown in 14 minutes if I click again, 12 hours if I click hard, 1 day if I click good, and 4 days if I click easy. Could you perhaps help me with how that would look in the settings?

My big master deck and my specific subdeck both have a new cards/day of 999. I personally haven’t added any new addons but here is a list of my old ones.

Your understanding is correct, with 14 1440 as steps, new cards answered with Again should be given a 14 minute delay, and Good should be shown the next day.

My apologies, it was late yesterday… Actually, for a new card (with the new scheduler enabled) the buttons should show something like <14m | 12.1h | 1d | 4d. So your settings seem to fit your intention.

Are you still experiencing this oddity? Because if the problem was this:

Then the strange intervals shouldn’t occur for cards you first saw after changing the settings.

As for your add-ons, I don’t know AMBOSS, but the other ones shouldn’t meddle with the scheduling.
You can check in the stats how many new cards there are available for a given deck (not sure whether it takes into account buried siblings though).
Apart from that, I dont’t have any more ideas. :confused:
Maybe you could report what happens to new cards after you you have pressed “Good” once. When do they appear again and what are the new available intervals?

For completely new cards, I see <14m 12.1hr 1d 1d. So I think everything besides the easy interval is somehow fixed on its own.

But now the card limit is my main problem because I need to do significantly more cards/day than it’s allowing me to.

For example for one subdeck, the statistics pie chart shows me I have 329 new cards and my parent and subdeck both have a new cards/day of 9999. However, Anki is only showing me 20 new cards for that subdeck and only 100 new cards for my parent as a whole.

I’ve been using Anki for around 2 months. I’m sorry it’s glitching like this now but I’m so thankful for your help.

Well, at least the problem with your new card intervals got better. However, the easy interval is still not fitting your settings.
I would disable all add-ons and restore the default deck settings. See if that works as it should and then manually adjust them to your liking.
I’m really just stabbing in the dark here.

The Easy interval will show up on Next review - along with the Graduating ivl; you will have two choices for graduating the card: 1d or 4d.

BTW, the Grad ivl value should be more than 1d – because it is too close to the 1440 step.

PS. It is safe to experiment; just change one option; click Show Answer; look at what Anki does and then - undo it ( use ‘Edit’ button at top left; confirmation pop-out is clearer than that of the Ctrl+Z ; and the message comes out BEFORE you click the button to undo the change).

You will need to check the daily limits you have set for each subdeck, not just the parent decks.

so today the card limit problem fixed on its own too!!

My Anki must have just been possessed or something haha I really appreciate your help throughout this struggle

this is so helpful! thank you!