I couldn't open anki - "resetting corrupt _global"

Please try renaming your prefs.db and prefs21.db files to something else. If that doesn’t help, please try renaming your entire Anki2 data folder.


I renamed both files and even renamed anki2 but it didn’t help. I still cannot open anki.

Can you try installing the:

  1. Latest version from https://apps.ankiweb.net/
  2. Latest alternate version from https://apps.ankiweb.net/
  3. If you are felling adventure, you can try installing the latest beta (and alternate beta) versions from https://betas.ankiweb.net/#/

Are you sure you did renamed your Anki directory (https://docs.ankiweb.net/#/files?id=file-locations)

It may also be worth checking for permission problems: https://faqs.ankiweb.net/windows-permission-problems.html

i renamed Anki2 here and try to open Anki app, but it didn’t open.

i can install the latest version but cannot open it.

still cannot open

  1. What version did you installed? Check your Anki version by calling anki-console.exe --help
  2. Did you try the 2.1.28alpha3?
  3. Did you try installing the alternate version?
  4. Did you tried running Anki as Administrator?
  5. Did you tried running Anki in compatibility mode?
  1. I installed 2.1.26 version.
  2. didn’t try
  3. I try install different version but still cannot open so i go back to the latest version.
  4. yes
  5. yes

if u curios I use window 10 pro

Please try the alternate version:

As Anki is not working by any means, why you do not try installing the beta versions?

i tried the alternate ver. already. Now I also try beta ver.

I will add some extra debug info in 2.1.28beta2 that may help discover what is causing this. Please wait for the next beta to come out, then run it with anki-console.exe