How to Install Add-ons

I imported add ons into my addons21 folder in the Anki program files folder.
Then, I installed an add-on messed up anki.
I hit “shift” when anki started, and all of my other add-ons disappeared, but they’re still located inside of that folder.
I even removed them from the folder and put them back in.
What am I supposed to do?

It happened because Anki toggle all the add-ons disabled when you press shift during initialization.

Press Ctrl + Shift + A (or go to Tools>Add-ons), then toggle one add-on disabled, restart Anki and see if the problem persist. If so, repeat this procedure until you find the add-on that’s causing the problem.

Once you find it, go to the add-on page, look for the link its author set to reporting issues (it’s usually a link to Github, but sometimes to Anki Forums instead).

Keep the add-on disabled (or uninstall it) until the issue is solved.

1 Like

There are no add-ons listed in the panel.
They’re all gone, despite them still being in the folder.
They were all “gone” after I hit shift.
How do I see them again?

The shift key does not touch your add-on folder. If your add-ons are suddenly missing, maybe you accidentally renamed the folder, or moved it to a different location? What happens when you add a new add-on?

No the folder is still there.
I cannot see anything on the list though.

If I add a new add on it will work.
But the other ones are missing from the big folder I have called addons21

I also tried removing folder and readding it.
It temporarily worked, and all my add-ons were refreshed.
Then, it gave me that nasty error message that says one of the addons is not compatible. It doesn’t give me the option to disable one by one. It just disabled all of them.

The problem is persisting.
I can’t figure out which add on is the problem since they’re all disabled.

Try enabling them one by one, and then restart, until you start seeing the error.

  1. For add-ons you can’t see in the add-ons list, can you check if there’s a file named right inside the add-on folder? (As in addons21/addon_id/ exists)

  2. Just to be sure, you are navigating to the addons21 folder by clicking Tools > Add-ons > View Files, right?

  3. It’s not impossible that an add-on is hiding itself or messing up with the add-on window. (Whether it’s a bug or deliberate) Try removing all the add-ons from the addons21 folder, and then re-add the add-ons one by one and re-launch Anki each time to see if they appear. When you can’t see the add-ons anymore, then the last one you added might be the problematic one.

This is what I was hoping not to do, but I may be forced to do it.
Oh well.

The folder I checked was empty.

I found the error:

An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue on the add-on support site.
Debug info:
Anki 2.1.47 (dc156f34) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Windows 10
Flags: frz=True ao=True sv=2
Add-ons, last update check: 2021-09-12 08:10:21

Caught exception:
Traceback (most recent call last):
File “aqt\”, line 208, in on_focus_changed
File “aqt\”, line 2533, in call
File “aqt\”, line 749, in on_focus_did_change
File “aqt\”, line 159, in refresh_if_needed
File “anki\”, line 364, in reset
File “anki\scheduler\”, line 80, in reset
File “anki\scheduler\”, line 87, in _reset_counts
File “anki\scheduler\”, line 52, in deck_due_tree
File “anki_backend\”, line 185, in deck_tree
File “google\protobuf\”, line 199, in ParseFromString
File “google\protobuf\internal\”, line 1139, in MergeFromString
File “google\protobuf\internal\”, line 1206, in InternalParse
File “google\protobuf\internal\”, line 733, in DecodeRepeatedField
File “google\protobuf\internal\”, line 1206, in InternalParse
File “google\protobuf\internal\”, line 733, in DecodeRepeatedField
File “google\protobuf\internal\”, line 1206, in InternalParse
File “google\protobuf\internal\”, line 733, in DecodeRepeatedField
File “google\protobuf\internal\”, line 1206, in InternalParse
File “google\protobuf\internal\”, line 733, in DecodeRepeatedField
File “google\protobuf\internal\”, line 1206, in InternalParse
File “google\protobuf\internal\”, line 733, in DecodeRepeatedField
File “google\protobuf\internal\”, line 380, in add
File “google\protobuf\internal\”, line 525, in init
File “google\protobuf\internal\”, line 1503, in init
RecursionError: maximum recursion depth exceeded while calling a Python object

Hey guys,
I figured it out!
It turns out the error is Adv Review Bar!
This is incompatible with 2.1.47! I hope someone will benefit from me.