Deck vanished, forum combing unsuccessful, backups also empty


I made a deck over the span of two days, nothing major, but when I synced to try to upload my file, I was prompted with the ankiweb option to upload or download. I proceeded to attempt to upload the file, but then my deck disappeared. I have combed forums and tried to restore backups to no avail. If I cannot retrieve deck successfully, then I at least want to understand what happened in order to avoid the same issues in the future.

Thank you

It looks like you chose “download” on your first sync, which will overwrite the local contents with the contents on AnkiWeb. A backup should have been created in that case however - I presume backups are enabled in the preferences screen? Did you check the backups folder? Restoring an Automatic Backup (Recovering from Data Loss) - Frequently Asked Questions

1 Like

Wow I’m sorry then. Yes I have tried to restore about 3 backups around that time period and none of them have the deck unfortunately.

An error occurred. Please start Anki while holding down the shift key, which will temporarily disable the add-ons you have installed.
If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.
When you’ve discovered the add-on that is causing the problem, please report the issue on the add-on support site.
Debug info:
Anki 2.1.38 (355e4cd5) Python 3.8.6 Qt 5.14.2 PyQt 5.14.2
Platform: Mac 10.16
Flags: frz=True ao=True sv=1
Add-ons, last update check: 2021-02-03 18:15:50
Add-ons possibly involved: ⁨Image Occlusion Enhanced for Anki 21 alpha⁩

Caught exception:
Traceback (most recent call last):
File “aqt/”, line 373, in accept
File “aqt/”, line 334, in doOpen
File “aqt/”, line 357, in _openBackup
File “aqt/”, line 282, in onOpenProfile
File “aqt/”, line 406, in loadProfile
File “aqt/”, line 2146, in call
File “anki/”, line 34, in runHook
File “/Users/jakesturgill/Library/Application Support/Anki2/addons21/1374772155/”, line 203, in onProfileLoaded
File “/Users/jakesturgill/Library/Application Support/Anki2/addons21/1374772155/”, line 78, in getSyncedConfig
if ‘imgocc’ not in mw.col.conf:
AttributeError: ‘NoneType’ object has no attribute ‘conf’

This is the error that I am presented with when I try to revert to the backup around the time of my blunder

And then I follow the error prompts to block add ons and use backup, and the backup is missing the deck as well

I’m afraid if you’re unable to locate the data in any backups, it has probably been lost. :frowning:

I just tried to reproduce this and found that Anki is not taking a backup when choosing “download”, which it used to do, so this functionality likely got accidentally lost when some code was moved about - I’ll look into it.