Copycat Importer (AnkiApp/AnkiPro)

Can you share your collection? You can use to upload it.

gofile. io/d/Wdl1G8

here you go
thanks alot

~/library/containers/ankiapp/data/documents/ankiapp (on macOS)

this is how i got the file if it helps

The database doesn’t actually contain any media files (And it’s only ~ 2 MB). Can you normally see the pictures in AnkiApp? Does the ~/library/containers/ankiapp folder contain any other interesting files? Maybe there are other database files hiding there in the folder.

All pictures can be viewed offline, I tried doing the same process this time with a windows computer, It produced the same results, with a file of ~2 mb. i’ve looked around and other than the cache folder. This folder contained the most “data”(~user/Appdata/roaming/ankiapp/IndexedDN/app_-_0.indexeddb.blob/1). 1 is a folder composed of 100+ different files with different sizes approx 200-300kb each.

here is a sample of one of the files
gofile. io/d/PGeV3o

Forgive me if i used the wrong terms

I see. The other file you shared is actually a PNG file, so it looks like this folder stores media files. Normally, AnkiApp stores the files directly in the database file along with the cards’ contents. This is the first time I see a different structure. Last time I worked on this add-on I tested with 4.8.8. I just tested with the most recent version (6.1.0), and guess what, they apparently changed how media files are stored! I’ll see whether I can add support for new versions. If you can share with me a zip of the whole AnkiApp folder under AppData that will be useful for testing.

Ahh I see, went around looking around for and older version ankiapp but coudn’t find anything.
But That’s great to hear :smiley: thanks for all the effort

had trouble uploading the entire file on gofile,
here it is on google drive:
bit. ly/3TMUMqR

I have version 4.8.8: Gofile - Your all-in-one storage solution

Try completely removing the newer version (along with the data inside AppData) and installing this version. Then see if you get a different result. The database file should now be much larger, as it contains all media files. If so, the add-on will work normally with it.

I found a trick to make media importing work with the newer version, and one damning thing about AnkiApp. Will post the details later.

have had no luck when using the old version. tried installing the old version after both deleting the app folder, and uninstalling the new versions. Amounted to same small file.

Thats great to hear, will stay tuned

I’ve pushed a hotfix for this. The add-on should now import the vast majority of your media files (Only 14 files missing at the end).

Now, let me go into the horrifying details of the issue: AnkiApp used to store media files inside a table in the database file. Internally, media files are referenced in the field contents using a special syntax (e.g. {{blob 6ef053d48e5f4c0b98160c095d5071e3}}). The add-on simply uses these “blob IDs” to know where to find the files. The problem with the new AnkiApp is that now the files are stored normally as separate files in a subfolder and not in the database file, and they have hexadecimal names (e.g. 1a.png, 1b.png) that don’t seem easily relatable to the blob IDs, so there does not seem to be there an obvious way to know the blob ID of a file now. After poking around for hours inside the AppData folder, I found a simple way to get the files, which is to download them directly from AnkiApp’s servers. And guess what, AnkiApp does absolutely no authentication to prevent unauthorized access to the files. Given the blob ID 6ef053d48e5f4c0b98160c095d5071e3, AnkiApp servers will happily give anyone on the internet the file at
It’s really that simple, and it’s one more reason to stop using AnkiApp and run away.


Thank you for revealing this to everyone, i have friends who use the ankiapp simply because its prettier. This should tell them otherwise.

As for the addon i still seem to have issues regarding the photos, it says media had been transfered but all cards with photos still have the curropted photo sign.

I see. Looks like there is some issue in how the add-on is downloading the files. Will look into it tomorrow.

Should be fixed now.

1 Like

Thank you so much, you really saved my ass and im sure alot more with this add on. Thanks for exposing ankiapp to be the fraud it is. Hope this continues to promote the shift from ankiapp to anki. I know its not much but bought you a kofi. Thanks again!



The add-on is only importing 20 cards from each deck. Is this a known issue?

I have each of these decks downloaded according to the ankiapp app.

On Windows 10 using the second to newest release.

Can you share your collection?

I figured out the issue. I had copied the file to the desktop as the open fire dialog was not showing AppData. When I was able to see AppData, I opened the file from the original location and it downloaded at least the correct number of cards.

Now I get to happily fid out if the are correct! Awesome

Or not, because the add-on claimed the right number of cards and decks didn’t show up. Also the old decks with the same name still only show 20 cards each

After deleting every possible thing related to Anki on my computer, and having restarted my computer and installed every possible version of Anki, the downloader will tell me it grabbed the correct amount of cards but only show 20 in each deck