Cloze not working- shows Empty card


I am having a major problem with Cloze.

The cards weren’t hiding the clozed information. So, I deleted my account, uninstalled anki from desktop and then created a new account and reinstalled anki.

Now, the Cloze card is showing up as a blank card and says to go to tools and empty the cards.

The following is the code in the card:

Front Template:

Back Template:

.card { font-family: arial; font-size: 20px; text-align: center; color: black; background-color: white; }

.cloze { font-weight: bold; color: blue; } .nightMode .cloze { color: lightblue; }

Please help with this issue.

Might be relevant.

1 Like

Thankyou for reverting.

I tried this. It says “no empty card”
Moreover, as per the solution shared- it says the problem arises when there’s been a change in cloze deletions in the note.
However, I had made no such changes: it was simple- I just created two cloze deletions and added the notes- which then says to run empty cards.

Maybe either take a short screen recording or post 3 screenshots - one is from the review window with the error message, then a screenshot after clicking on the Edit button to see the fields’ content and then a screenshot after clicking on the Cards button to see the front template.!AvGdCCz5YE1EgucuMWJqTjs3Ztfgng

Please follow the link above for the screen recording.

1 Like

That’s not how cloze notes work. Please read this to fix the cloze deletion:

However, cloze deletion isn’t suited for your example in the first place. So maybe you won’t need it at all.


@Rumo is right and if it’s still not clear what went wrong and how to fix it, here’s a quote from the above manual.

To create a cloze deletion note, select the Cloze note type, and type some text into the “Text” field.

This is because the front and back templates contain {{cloze:Text}} and Anki expects to find cloze deletions in the “Text” field, not in the “Back Extra” field.


Oh my god! I understood what I was doing wrong: I was typing in back extra field! Thankyou so much! It is working now.
Its kinda odd. When I first used anki and I created cards with the method as I showed above- it was working fine.

But thankyou for your help!