BUG: Can't select Japanese word candidates when adding a word on MacOS

Basically the same issue reported here:
and here:

But I don’t think a solution was truly given in either case. At least neither of the two suggestions solved the problem for me.

When writing in Japanese you press the space bar to select among kanji candidates. This works perfectly across the computer except in Anki when writing directly on a field. Even the browser search input field works fine, but typing directly into a card’s field doesn’t, so I am not sure what the problem is.

Normally I have to write the word somewhere else and cut/paste it into Anki, but these days I am needing to add many Japanese words and wish I could solve the root of the problem instead as the workaround takes a lot of time.

Any help would be greatly appreciated.

Anki 23.12.1 (1a1d4d54) (ao)
Python 3.9.15 Qt 6.5.3 PyQt 6.5.3
Platform: macOS-14.3.1-arm64-arm-64bit

===Add-ons (active)===
(add-on provided name [Add-on folder, installed at, version, is config changed])
Advanced Browser [‘874215009’, 2023-10-21T23:34, ‘None’, ‘’]
AnkiConnect [‘2055492159’, 2024-01-22T07:03, ‘None’, ‘’]
AwesomeTTS - Add speech to your flashcards [‘1436550454’, 2024-02-09T15:42, ‘None’, ‘’]
Batch Editing [‘291119185’, 2023-10-26T09:38, ‘None’, ‘’]
FSRS4Anki Helper [‘759844606’, 2024-02-18T18:32, ‘None’, mod]
HyperTTS - Add speech to your flashcards [‘111623432’, 2024-02-10T21:02, ‘None’, mod]
Japanese Example Sentences [‘2413435972’, 2019-02-21T04:40, ‘None’, mod]
Japanese Support [‘3918629684’, 2023-10-19T12:13, ‘None’, ‘’]
Local Audio Server for Yomichan [‘1045800357’, 2023-06-19T12:57, ‘None’, ‘’]
Symbols [‘1461102936’, 2024-02-11T01:53, ‘None’, ‘’]
Yomichan Forvo Server [‘580654285’, 2023-08-31T05:53, ‘None’, ‘’]
extended editor for field for tables searchreplace [‘805891399’, 2023-07-31T23:12, ‘None’, mod]

===IDs of active AnkiWeb add-ons===
1045800357 111623432 1436550454 1461102936 2055492159 2413435972 291119185 3918629684 580654285 759844606 805891399 874215009

===Add-ons (inactive)===
(add-on provided name [Add-on folder, installed at, version, is config changed])

1 Like

It’s a bug in the current toolkit version. Until Anki gets another release, using the -qt5 version of Anki should work around the problem.

1 Like

Me, too, the same issue. Hope it can be fixed. Thank you!

Thanks for the response @dae, when you say “until Anki gets another release,” what do you exactly mean? Is this a major release that could take months or years or just the next update? I think this bug has been around for quite some time now, and since, as far as I understand, Anki started as a tool to help in studying Japanese, it would be great if it can be solved with some degree of priority.

Using the qt5 doesn’t seem to be an option for me as it would break compatibility with the add ons I rely on.

Thanks for your hard work and for taking the time to reply. Anki has been sooo helpful in the almost ten years I’ve been using it. :smiling_face:


It should have been fixed with the 24.04 beta1, which should release as stable in a few weeks. You can find the betas here if you don’t feel like waiting:

1 Like

Thanks @Gustaf-C ! I will totally update to the beta. This will be so helpful, you guys are amazing! :star_struck:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.