Browser Search Box: Quick Insert Tag, Deck, Notetype [Official thread]

If you have a problem with this add-on post in this thread. This way I get notified. If you make a new thread I will likely miss it.

Hi there!
There is a huge lag in pulling up the search box, is there a particular reason for this? Do I have too many add-ons? Any help appreciated thank you!!

I don’t have this problem and have never heard of it before. But maybe you’re the first one to report it? So I need your help.

Since when do you have this problem: Always or only after the latest update?

Could you try again without any other add-ons in the latest version (Anki 2.1.26)? Is it still slow?

Is it slow for tags, notes, decks, cards, fields, etc. or only for one such dialog?

It’s important to test with the latest Anki version.

To keep your current set of add-ons: I would close Anki, then rename your addons21 folder, then restart Anki (which creates an empty addons21 folder) and then install my add-on, then restart. Is it faster now?

To find your addon folder:

1 Like

Hi, I noticed you updated the add-on today to require Anki 2.1.28. I am on 2.1.26, so the add-on does not work, and I find it very useful for my workflow. Version 2.1.28 is still a beta version, so are we required to use the beta to use your add-on? Can you keep the older version available until Anki 2.1.28 is officially released? Thanks!

@sd23: Thanks for this info. I wanted to offer to two different version but by accident I removed the old version. I’ve re-uploaded the regular one. If it still doesn’t work for you let me know.


Hi, when I try to change “-Modify Search Bar” to “multiline” I get the following error message:
Invalid configuration: JSONDecodeError(‘Expecting value:line 3 column 27 (char79)’)
I’ve tried disabling all my other add ons to see if there was conflict, but I haven’t been successful. Do you have any advice on how to fix this?

1 Like

This sounds like an error in your configuration file. I guess you get this message when you try to close the config window?

Have a look at the line 3 of your config file and check it again.

The top of the config should look like this:

    "-Add Button to the Browser Search Bar": true,
    "-Modify Search Bar": "multiline",
    "-Multiline bar Auto Search on space": true,


When you adjust the config for an add-on in this extra window you actually edit a so-called “json” file. This means you must strictly adhere to the json rules or you will get such weird error messages.

It’s not ideal. But but better than no option to config add-ons or forcing add-on creators to invest much time into writing nice dialog with buttons which would mean that I wouldn’t invest any time into offering config options.

The json format is actually pretty simple. Maybe google “json file syntax” for a short introduction which will help will all add-ons in the future. There are also websites where you can paste your json code which highlight invalid parts which makes it easier to fix it

Also see e.g. here.


If it doesn’t work for you: Post your whole config here. Make sure that you format the config on this page as “Preformatted text (Ctrl+Shift+C)” from the top icon bar of the box where you write your text on this page.

1 Like

Good day! I tried to watch all AnKing Videos. and one of those is your add on. at first I was able to use the Date added. But when things mixed up. I can’t use the date added, date rated, and date edited. Some of the features still be used. I deleted all add ons and reinstalled only the addon. but still the same.

If the issue only occurs when add-ons are enabled, please use the Tools > Add-ons menu item to disable some add-ons and restart Anki, repeating until you discover the add-on that is causing the problem.

When you’ve discovered the add-on that is causing the problem, please report the issue on the add-on support site.

Debug info:

Anki 2.1.33 (3f403040) Python 3.8.0 Qt 5.14.1 PyQt 5.14.1

Platform: Windows 10

Flags: frz=True ao=True sv=2

Add-ons, last update check: 2020-09-11 19:55:24

Caught exception:

Traceback (most recent call last):

File “anki\”, line 35, in get_immutable

File “anki\”, line 570, in get_config_json

File “anki\”, line 265, in _run_command


During handling of the above exception, another exception occurred:

Traceback (most recent call last):

File “C:\Users\Admin\AppData\Roaming\Anki2\addons21\1052724801\”, line 161, in

self.form.pb_date_rated.clicked.connect(lambda _, a=dr: self.onButton(a))

File “C:\Users\Admin\AppData\Roaming\Anki2\addons21\1052724801\”, line 166, in onButton

button_helper(self.form.pte, self.browser,, self.col, arg, remove_on_cancel)

File “C:\Users\Admin\AppData\Roaming\Anki2\addons21\1052724801\”, line 12, in button_helper

_button_helper(pte, parent, mw, col, arg, remove_on_cancel)

File “C:\Users\Admin\AppData\Roaming\Anki2\addons21\1052724801\”, line 43, in _button_helper

text_change_helper(pte, parent, mw, col, before=all_text, before_pos=pos)

File “C:\Users\Admin\AppData\Roaming\Anki2\addons21\1052724801\”, line 49, in text_change_helper

out = onSearchEditTextChange(

File “C:\Users\Admin\AppData\Roaming\Anki2\addons21\1052724801\”, line 103, in onSearchEditTextChange

return range_dialog(parent, term, before, after, length, func_settext)

File “C:\Users\Admin\AppData\Roaming\Anki2\addons21\1052724801\”, line 26, in range_dialog

d = DateRangeDialog(parent, term)

File “C:\Users\Admin\AppData\Roaming\Anki2\addons21\1052724801\”, line 66, in init

self.today_in_dt = today_as_datetime_adjusted_for_next_day_starts_at()

File “C:\Users\Admin\AppData\Roaming\Anki2\addons21\1052724801\”, line 28, in today_as_datetime_adjusted_for_next_day_starts_at

dayOffset = mw.col.conf[“rollover”] # by default 4

File “anki\”, line 49, in getitem

File “anki\”, line 37, in get_immutable


@micsibulo: Thanks for this report. Could you update your add-ons and try again. I have just uploaded a new version to Ankiweb that should fix this problem. If you still run into this problem or another problem let me know.

Wow! Works perfectly now! How can I thank you???
Thank you for your generosity and sharing your expertise. I am studying for USMLE thank you big help!

I meet this question too

Put a double quotes around down >> “down”

Just a heads up, looks like 2.1.39beta1 changes the filter button and sidebar stuff and some of the BetterSearch buttons don’t do anything now

Thanks for notifying me. I’ll update the listing once 2.1.39 is closer to release (in case there are more changes to the recently chagned sidebar and searching code).

And I really hope that today will be a good day for you and your family.

1 Like

Looks like 2.1.41beta2 has similar changes. Damien said he doesn’t expect that much of a change from this point. It seems the tag and deck searching functions are no longer needed, but I think the searching functions will still be useful

I just uploaded a new version of BetterSearch that should work with 2.1.41. It’s not much tested and I split up a big file into smaller ones which can always introduce some problems. If you find any please let me know.

Seems to work well now. When pulling up the dialog with the shortcut, the deck, tag and card state buttons no longer work but everything else seems to work fine

@ijgnd suggestion for 2.1.41+ would be to add a button on the fastbar add-on for this? Just if you’re bored or have free time

Just want to report this peerless search addon doesnt work under Version ⁨2.1.44 (b2b3275f)⁩.
Any solusions?
Kind regards,