Apple Silicon, 2.1.53 Qt6 — ONLY opens in Admin account

I’ve seen there have been probs with opening recent Anki versions on Macs; the latest Anki opens fine … but in an admin account ONLY.

When I try to open Anki in my normal USER account, I get:

“you can’t open the application because this application is not supported on this mac”

If is in


then it cannot be started from within a user account.

But if is in


then I can start Anki from within the user account ‘me’.

In older versions of Anki, I would always be able to start /Applications/

even from within user accounts.

I suspect you have several Anki versions installed in your computer, one of which is in /Applications/, one of which is in /Users/whatever/Applications/. From now on, only speculation, because I’ve never used a Mac in my life so I don’t really know how it works (but it should comply to some extent to the unix logic, so it’s enlightened speculation): the version installed in /Applications/ is the latest compatible version, installed system-wide. Everyone can launch it, and it works fine, that’s why when you start it with the admin account, everything works. On the other hand, the version installed in /Users/whatever/Applications/ is an incompatible one, installed only for the user whatever. Even though both versions are available from whatever‘s standpoint, just launching Anki will select the version in /Users/whatever/Applications/ because it comes first in the users’ PATH (which is logic: if there is an application installed system-wide, but, as a user, I still install an other version, it means I am interested in the latter, not the former). If this is correct, typing /Applications/ in a terminal as a user should work.

Also, I don’t know how you understood that Anki was running fine as an admin, but I suspect you “just tried what would happen if I ran that app as an admin”. If that’s the case, I would highly suggest you not doing that anymore, as it can be very dangerous. All debugging should be possible without granting admin access to the app that is not working.


Thanks for replying …

I’ll stick with 2.1.49 for the time being … :wink:

I ran into the same issue and found a workaround, if you’re comfortable using the command line.

I describe it in on GitHub as issue 1934 but I can’t post the issue link here.

I also describe a workaround that worked for me. If you go to the command line, and do the following, it will modify the Anki bundle’s files’ user group to “staff”:

cd /Applications 
sudo chgrp -R staff

But I make no guarantees and I would not recommend you to execute these commands unless they make sense to you.

1 Like

I am seeing the same problem on 2.1.54 Qt6 on an Intel Mac running Catalina (10.15.7). Algal’s solution confirms what I suspect, that is, the problem is a permissions issue. I noticed that /Applications/ has the permissions

These UNIX permissions mean that the “others” cannot execute the application. I normally use a separate administrator account from my own user account to install applications, giving different permissions for that administrator account than my own standard account. I first noticed this problem in 2.1.52. I tried to increase the permissions only on the anki executable, but it still did not work. I thought that the permissions likely were incorrect elsewhere in the bundle. Algal’s solution likely worked because he changed the group permissions of to a group of which he is a member.

Since I usually am the only Anki user on this computer, rather than trying to correct the downloaded bundle’s permissions issue, I just installed into the /Applications folder from my own account. While this fix satisfies my needs for now, the permissions need to be fixed in the distributed bundle. I had hoped that this issue would be caught by the developer without my needing to submit a bug report, but two releases later the bug still is there. Thank you auntanki for creating this thread.

This was reported on Cannot run as standard user on macOS (description, diagnosis, and workaround) · Issue #1934 · ankitects/anki · GitHub