Anki opens in Monterey admin profile but not standard user

I recently upgraded to Monterey/Apple silicon. Normally I have 3 profiles on a system: Admin (updates, installs), backup Admin, and Standard User (normal day-to-day). I have installed Apple Silicon 2.1.54 Qt6. I always open a program in admin mode to be sure it works (it opens fine). However, when I am in standard user mode, the program does not launch; I get the following error:

You can’t open the application “” because this application is not supported on the Mac.

Anki worked fine on my previous (Intel) system (with the same profile setup).

I would like to stay with Anki but, obviously, if it won’t open, I will have to try another program.

Anki has been installed in /Applications. I have used AppCleaner & EasyFind to clean out previous attempted installs.

Current system: MacOS 12.6.1

Does the problem persist with 2.1.55 beta2? (3 is currently broken on Apple silicon)

I don’t know – I don’t generally put beta products on a production machine. I would be doubly cautious if a subsequent update undid the previous improvement. I really don’t have time to continually install/uninstall a program (I have already done it several times since 2.1.49). Perhaps I should just wait until the next release. If the problem still hasn’t been fixed, then it will definitely be time for me to find an alternative program (happy though I otherwise am with Anki). Thanks, though, for the suggestion.

A while ago I stumbled upon the same problem

Just this one time, you might be inclined to make an exception: just install Anki in /Users/nonadmin-work-HORSES/Applications/ :smiley:

Anki works perfectly when installed in a non-admin user account; and no, you’re NOT going to find anything better than Anki, not even close … :wink:

Hope this helps …

Thanks auntanki for the reminder that I could always just install for the standard user. I will do so for the moment, But it is really annoying that a program which was always appropriately coded to install in /Applications and be usable by all, suddenly won’t. Even more annoying is that they apparently fixed it in 2.1.55 beta2 and then unfixed it in 2.1.55 beta3. Grrrr.

(and, having looked at the so-called alternatives to Anki, I think I will have to agree with your assessment.)

thanks to auntanki – I created an application folder in my user profile. Anki now opens and works.

(but Anki used to be coded appropriately so that it could be installed in /Applications and open in all profiles).

thanks again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.