Issue running 2.1.28 on Big Sur

i tried opening the 2.1.28 stable release on mac, but it says the application is damaged. i tried redownloading to no avail, and tried disabling the error message with “xattr -cr /Applications/” which just caused the app to ‘freeze’ (btw not a single anki window actually opens, the reason i know its frozen is because why i right click the applcation in the application bar it has the option for ‘force quit’ instead of ‘quit’)

The download works for me - I don’t get any damaged message, and it starts up properly. Perhaps your download is corrupt? Tried downloading again with a different browser? Do you use a third-party antivirus program?

just tried disabling addons by re-naming the addon folder, and that caused the profile window to open, although the window is blank & still frozen

tried beta 1, 5 & 6 and none open

i’m guessing it must be because i’m on macos big sur beta2, but i’ve experienced literally zero bugs on it thus far, and anki 2.1.26 runned fine.

also i can’t open my main profile in 2.1.26 anymore as i get a popup about forgetting to downgrade profile, so is there any workaround to that since i can’t actually open 2.1.28 in the first play to be able to downgrade?

Are you using dark mode? If so, did you see the note in the changes about disabling dark mode?

You can use the open backup button to open a backup made before you upgraded if you’re unable to open the app.

nope, not using darkmode, and thanks for the tip about opening a backup :slight_smile:

i just checked the console when it opens and this is what i got (the circled activity in image1 is the one that seems to be the issue as it is the only one with extra messages when you click on it (image2), with some showing errors — idk what it means ??):

It could be Apple have changed or accidentally broken something to do with app signing, which would explain why it told you the download was corrupt. Might be worth reporting the issue to them using the feedback tool.

You could also try the -alternate version of Anki, which uses an older toolkit, in case it makes a difference.

alright, thanks :slight_smile:

2.1.29beta1 seemed to load after a few min of being frozen, and now it runs fine (opens quickly again). issue resolved i guess ~

Interesting. I wonder whether it was updating the macOS SDK for the packaged build, something Apple fixed in the backend, or something else.

@ornfl have you tested 2.1.30? I’m on that currently and would like to test the Big Sur beta, but I need anki running for my medical rotations

yeah 2.1.30 runs fine