All of My Decks are Gone/Restoration Is Blocked

I am trying to open Anki as I do every day as a medical student, and I cannot access any of my cards/they seem to have been wiped from my account.

When I open Anki, I receive this message:

Then, when I try to open my username, I receive this message:

Then, when I try to restore a backup, I receive this message:

How can I adequately restore an old backup? I have tried restarting my computer and closing the application as the instructions suggest, but this does not work and I end up with the same messages again. I also tried making a second user account and restoring a backup there, but that also failed. Additionally, I can’t access the preferences within the Application when I try to fix the restoration settings. Lastly, I am using a Mac running Big Sur Version 11.2.3.

The first error message is caused by the Advanced Browser add-on. You may have to disable it.
See When problems occur - Frequently Asked Questions

Regarding the second error, this could be relevant:


Thank you very much! I installed the latest version of Anki and my full collection was restored! Moral of the story: keep your apps up to date!