AnkiMobile cards showing "no cloze found", but AnkiDesktop works fine?

I am having trouble with AnkiMobile on my iPad. Most of my cloze deletion cards in several of my decks are saying “no cloze found,” but the cloze is inserted correctly. I have uploaded two images showing the error message I receive, and then the contents of the card giving me the error. However, when I study the same deck on my laptop I do not have this issue and my cards all load fine. I have tried restarting my iPad, checked for updates on the web but I haven’t found anything. What can I do?

Use the empty cards tool to fix the issue

Tools → Empty Cards (Anki desktop)
Cog symbol → Empty Cards (anki mobile)

When you edit a previously added note, Anki will automatically create extra cards if they were previously blank but no longer are. If your edits have made some cards blank when they previously were not, however, Anki will not delete them immediately, as that could lead to accidental data loss. To remove the empty cards, go to Tools → Empty Cards in the main window. You will be shown a list of empty cards and be given the option to delete them.

this tool will fix the no cloze issue, it won’t delete cards

Your cards don’t display correctly for me in the latest computer version either, as {{C2::…}} is not valid cloze syntax - it should be {{c2::…}. You should be able to resolve the issue by using Find&Replace in the Browse screen, by selecting all your cloze cards, then replacing:




with regular expressions enabled.

I tried editing the syntax and it did not work. However, all of my cloze cards work on my laptop - I am able to study my cards just fine. The same cards just give me that error sign when I try to study them on my iPad. I tried the empty cards feature and for some reason it deleted a lot of my cards, and I was still getting the error for the remaining cards.

You should not empty cards until this problem is resolved, as you’ll lose your progress that way. You’ll need to restore from a backup if you have not already. Restoring an Automatic Backup (Recovering from Data Loss) - Frequently Asked Questions

You still appear to have a bunch of notes using capital C in clozes. Please try the steps I posted above again, making sure to select all cards, or disable the option limiting the replacement to selected cards. If you continue to have trouble after that, please take a screenshot of what you’re putting in the find&replace screen.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.