Anki stopped working on MacOS

Hi all,
Anki has been working fine on my Mac (Monterey 12.2.1) until today.
What changed:

  • I updated an Anki addon
  • I think there was a Chrome update (this should be irrelevant)

What happened:
Anki just won’t start up. Process hangs, there’s no error message. I have to kill the process to get rid of it

What I tried:

  • start from the command line. No messages to tell me what’s going on
  • removed Anki app and all user data (Library/Application Support/Anki*), including Decks, addons, etc
  • reinstalled Anki

The issue persists! I am at a loss - it would help if there were at least some messages or logs to check and know what causes this problem.

Any suggestions at all are very appreciated.
Thank you

You seem to have done most of the usual troubleshooting. But anyway can you have a look here just to be sure:

When problems occur - Frequently Asked Questions (


1 Like

Thank you! Yes, I’ve gone through all (applicable steps) in that list.
To clarify, I don’t have any decks right now (I moved them out of the way), and I am using a pristine installation of Anki, version 2.1.49


Which addon?

I know you’ve removed it - but we need to start somewhere.

if I remember correctly, it was ReColor

There are no issues reported on the ReColor page. All positive reviews.

However, they did mention restarting your computer. Have you done that?

This seems to be a known issue, but not resolved in the following link:

Anki won’t open on MacOS - Anki Desktop - Anki Forums (


Post #8 worked in that link. I didn’t notice on my first pass. There are about 30 posts:

"Seems to work! Will post what I did for others who might be looking for a solution to this problem:

I deleted Anki from my apps folder, re-downloaded “anki-2.1.50+beta1_43c41d76-mac-qt6-intel.dmg” from the link dae gave above. When I clicked the icon, it still bounces but doesn’t open, but when I invoke it via terminal (/Applications/ it then opened."

ah, thank you, I’ll give that a go!

Unfortunately the beta version didn’t work either. I tried both the one build with QT6 and the one built with QT5, but the result was the same:

Anki starting...
Initial setup...

and it just hang there
To answer your previous question, yes, I did reboot my computer

Ok, I’ve made some progress, in that I found out it’s most likely permission related: I tried starting Anki as root and it worked!

1 Like

That’s good news.

Maybe you could continue as root until you get a response from the pros here.

If I were you, I would close everything else while working as root - just to be on the safe side. I come from a UNIX background - now Linux. I was always nervous working at the “#” prompt. (Of course, there was no “Are you sure ?” popup.)

BTW: on the link that I posted, two other users eventually succeeded, and one other user failed. So, you might want to read to the end of that post - unless you have already done so.


This worked for me. Somehow my home dir permissions must’ve been broken (thank you MacOS for no helpful messages or logs whatsoever!). I’ll cross post in the other thread as well, maybe it helps someone. Thanks for your assistance!

diskutil resetUserPermissions / `id -u`
1 Like