Anki won't open on MacOS

Does the problem come back if you open Anki outside of a terminal again? If so, is it possible you have another copy of Anki on your computer, such as in your user’s Applications folder instead of the system one?

1 Like

No it now opens completely normally. There is no anki app in my user’s application folder.

Well that’s a mystery, but glad it’s working now.

Im having the same issue…I updated my Anki and Mac software to macOS Monterey and now the application just bounces up and down and wont open. The only option I have is to force quit. Please help

Please try the steps mentioned above with the qt6-beta.

I updated both my computer software and Anki and the same time and now I cannot open Anki. It bounces up and down on the toolbar but does not open or give any error message. The only “prompt” I get is to Force quit the app when right-clicking it.

Has anyone else experienced this and been able to fix it? I’ve downloaded older versions of Anki and restarted my computer a few times with no luck.


tried all 3 of these and restarted my computer in between each download and it is still not working…the app bounces up and down but dost open

I get this message: ASP: Security policy would not allow process: 5619, /Applications/

Sounds like Macos might be blocking the app, since Apple usually requires apps to be signed by “verified developers”. I can’t speak for Monterey, though here are some troubleshooting steps I’ve used on Catalina:

  1. “System Preferences → Security and Privacy” and check to make sure “app store and identified developers” is selected
  2. If you want to take the above further, run sudo spctl --master-disable in terminal. This alone won’t change anything. Navigate to the same location as step 1 and select “Anywhere”
  3. An odd step that sometimes works is opening the app manually. Open Finder and navigate to Applications on the left menu. Find anki and right click the app icon. Click “Open” from the menu
  4. If above still doesn’t work, brew might be able to install it better. If you aren’t familiar with command line, this may seem dangerous, though it’s really just installing the app
  • Head over to and copy/paste the top line on their site into terminal
  • Once it’s setup, run brew install --cask anki. You might need to delete the dysfunctional anki installation beforehand. Make sure you’ve backed your collection up somewhere

The app is signed and notarized, so changing the security settings from the defaults should not be necessary. I’d recommend against selecting ‘anywhere’ unless you’re planning to change it back immediately after testing. @Nickie, are you using one of the new Apple Silicon Macs? Is your macOS version fully up to date, or are there updates pending that you haven’t installed yet? This issue may be related to Anki App will not open - #6 by Alison

no, its my 2017 MacBook pro. Anki was working perfectly until I updated both the mac software to Monterey and updated my Anki (I got a notification that it needed to be updated when opening the app)

What is the macOS version shown in Apple menu→About This Mac?

Maybe the error was “is a directory”, since this message often pops-up when a software is trying to read from a file, that there is something at the path of the wanted file, but it’s a directory, not a file.
So my guess is that somehow, a directory was created in the App folder, in place of a file that should have been loaded to launch Anki properly, which is why deleting this directory and re-installing from source solved the issue.
If this happens again, to debug this issue, I would recommend using strace to see what are the last files the applications tried to open just before freezing, and then checking them one-by-one to ensure they really are files, and not directories.

macOS Monterey Version 12.1

The layout of the .app folder has changed a few times, and the path mentioned above is a folder in 2.1.49, but not in the 2.1.50 beta.

@Nickie I tried an install on a different machine running 12.1, but can’t seem to reproduce this problem, and I’m afraid I’m not sure what might be causing it. The only other thing that might be worth trying is to rename your prefs21.db file in your data folder to something else, then start Anki normally - does that help at all?

Hi! I’ve had the same issue as you with my Mac after updating my Anki app. I’m having an issue with opening it with terminal. Can you please share exactly what I need to type into Terminal after the “%” ? I’m not very familiar with how this works. Thank you!

I think just typing anki then pressing Enter should work (because Anki should be in your PATH).
If it doesn’t work, try /Applications/

1 Like

It finally worked, thank you so much! The app was frozen when I first got it to open, but I force quit and then re-opened it while holding down “Shift” and everything looks good!

If it goes well when you hold Shift, it means that the issue is (most likely) an add-on. You can find out which one by disabling batches of add-ons until it works.

I’ve had a similar problem and for me the solution was to fix the permissions of my home folder by running:

diskutil resetUserPermissions / `id -u`

I hope this helps!

1 Like