Anki getting stalled with error message when installing latest version 2.1.28. Kindly help

Till yesterday, i was using Anki 2.1.26 on my windows 10 computer.

While updating Anki on my computer with the latest version, I am getting an error message. I tried to download again and retry after restarting and deleting previous Anki files but to no avail.

Now all the previous versions are also not getting installed. Getting the same error in all.
Have tried to quit anything similar running on task manager, deleting Anki files from my program files and restarting, deactivating the antivirus and reinstalling, installing the alternate version, did troubleshoot, ran as administrator during all my attempts to install both the 2.1.26 and 2.1.28 versions.
Also googled and tried few other things mentioned on reddit, similar issues on this forum. But nothing seems to work.

No Anki version is installing on my computer now( getting the same error) even though the 2.1.26 version worked perfectly fine till yesterday before I tried to install the new version.

I donot know know else to do. Kindly help.

Please try restarting your computer, and if problems persist, manually removing the Anki program folder then installing again.

Thank you for your reply, Damien.

I have tried both of these things, no success till now.

Were you able to fully remove the program folder? If so, and you’ve ruled out antivirus programs, I’m afraid I’m not sure what the issue might be.

Re the private message you sent me, since this issue seems limited to your computer, you will need to experiment to see if you can discover the cause. If you use a third-party antivirus program, uninstalling it may help. You could also try installing in a different location to see if that makes any difference. And you could try manually copying the program folder from another computer to see what happens.

1 Like

this happened to me yesterday, solved itself immediately and i wasn’t able to reproduce it today.

i had 2 versions of anki installed, one on C drive and the other one on E (both of which 2.1.29 beta1)
tried to downgrade the one that’s on E drive to 2.1.28 beta6 got this error.
pressed retry, but nothing happened.
then i pressed cancel and after that i opened the installation folder on E drive to manually delete files, but the files were deleted automatically.
then after that i tried to install 2.1.28 beta6 again (in E drive), and i was able to do it with no error. (have a bitdefender antivirus which sometimes prevents apps from modifying files in C drive, but as the installation folder for that version was on E drive, i don’t think the antivirus was cause of that error)

(don’t know how this is gonna help tbh as i tried to reproduce the error but wasn’t successful)

1 Like

Hey Damien,

I uninstalled the antivirus and it worked.

Thanks a lot.

Definitely the best thing to do!