Anki Forums

Problems upgrading to Anki 2.1.34

I had Anki Desktop version 2.1.15, and when I opened it today it suggested an upgrade to version 2.1.34. When I followed the link it took me to Anki’s home page. I clicked the download button, and I read that for versions newer than 2.1.6 I don’t need to uninstall Anki before I install new one.
And so I downloaded the installer for the standard version 2.1.34, and started the installation. However, about 30 seconds into the installation, an error code came up, and I had to cancel the installation.
I thought that maybe not uninstalling Anki first was the problem, so I tried to uninstall the old Anki but a message came up saying it may have already been uninstalled.
The error code that appears during installation is as follows:

Error opening file for writing:
C:\Program Files\Anki\d3dcompiler_47.dll
Click Retry to try again, or Cancel to stop the installation.

Retry doesn’t work.

I would really appreciate it if someone could help me find a solution for this.
Thank you.

Maybe Anki didn’t close cleanly and is still running in the background. Try killing it from Task Manager.

Unfortunately it’s not showing as still running on Task Manager.
Thank you for trying and please let me know if you have any more ideas. :grinning:

There is actually a section about this on the download site.

See https://apps.ankiweb.net/#download

1 Like

Did you try deleting the C:\Program Files\Anki\ folder manually? Because it sounds like the uninstalling didn’t work properly and there are files left which block the reinstallation.
You can also try to run the installation as admin (I assume you have already tried rebooting).

I completely forgot to try restarting! Tried it now, and it worked!

Thank you so much for your help guys!