Unable to succesfully donwload 2.1.46

My previous update was 2.1.40 and today when I tried to download the 2.1.46 version, the program did not open (not even by pressing shift). I tried restarting the computer and checking for updates but nothing seemed to work. I then proceeded to download the alternate version and at first it was giving me a hard time by popping up a window saying “Error opening file for writing:…”. After multiple tries (of restarting the computer and deleting the app), it finally did work but I really want to update it to the newest version. What should I do? HELP :frowning:

Happened to me too. Had to uninstall all versions of Anki and then reinstall. Idk what caused the problem.

It may be that a file is open and can’t be overwritten, which can usually be solved with a restart.

I have done that multiple times and is not working.

Other possibilities are your antivirus blocking the installer, or file permission problems, which you may be able to work around by installing Anki in a different location.