Anki Forums

Anki compeletly broke for me


Tried deleting the app, replacing data from backup, switching to other user, turning off all extensions but I can’t even view any of my cards! Even the very new ones! Android version still works fine And looks like my data is still there but for some reason the mac app completely broke, even tried downgrading to older versions.
What should I do? Please help

Maybe a firewall or a VPN is causing the issue?


I use VPN but now it’s turned off

You could try editing HTML in reviewer panel,
to see if contents of fields are equal to those On ankidroid/ios anki
If so,to see if picture path contained in card field/note is valid related to picture path in Anki collection path


Here’s what I get when try to add new card, so as you can see, I can’t even make the card!
by the way, when I click options near the deck, it shows that the link is broken,that applies to every deck, even the new that I have just imported using extension import from quizlet, and the funniest thing that is synced perfectly with android app, it works! But not on my mac
I don’t really know what happened to my anki app on mac, I haven’t touched it for a while (a few weeks) and when i opened it, found out that it’s unusable

It must have to do something with your Internet settings. You can see in the error screen, that Anki tries to receive something from its private server (which runs locally on your computer), but it cannot reach it.

Here’s my network settings. Probably not here, what should I do now?

This is probably either your network settings for your entire system (eg a custom proxy/VPN), or some other software like an antivirus program that is running on your machine.

I don’t have any antiviruses. VPN - Cloudflare WARP, but it’s disabled for now. And I don’t remember making any tweaks to my network settings

At this point I’d recommend looking into why 127.0.0.1 is returning “invalid address”, and maybe contacting Apple support if some Googling does not provide anything helpful.

Oh my god, have restarted my computer and now it works!




I really hope this won’t happen ever again :sneezing_face: