Ultimate Birds deck

This is the forum for the Ultimate Birds deck.
Post your questions, issues or suggestions about the deck here.

Hey :slight_smile:

Looks like a pretty impressive deck!

Everything seems to work fine for me, except for the audio. It does not play the audio when i study the card or preview a card in the browser (options of the deck are set to automatically play the audio). Clicking the play button does also not result in the audio being played.

This is not the case for other cards in my deck, which use the “regular” way of uploading a local audio file. For them the audio works fine.

Am i doing something wrong on my part? Maybe you can help me out :slight_smile:

As i said, otherwise this seems like an amazing resource, and the “picture > birdname” cards work totally fine.

Can I know which platform you are using?

Assuming you don’t just have a very poor internet connection here is a test deck with four different ways of playing audio. They all work for me on Windows and AnkiDroid. Let me know which ones work for you.

https://drive.google.com/file/d/16jHZKGWtnSg2pJLVsE3Qz5gz1qq_XAgC/view?usp=sharing

I was using Linux Mint 20.3 Cinnamon (Edge) Edition.

3 out of the 4 Notes of your “audio reference test” deck worked. Only the second one “Audio from url” did not work.

“Audio downloaded”, “Audio with url from html” and “Audio with url from html (autoplay)” all worked flawlessly.

I now tried it out in Windows 10 (on the same Laptop) and every version worked, as well as your original deck. So maybe this is something quirky in Linux/Linux Mint?

The deck is updated now to use the new audio player. Try and see if everything works.

Yes, now it works on Linux Mint as well :smiley:

I imagine some people would like to be able to set the audio to automatically play when reviewing the card. Is there some css option to do this, or is search-replacing the html tag the only option here?

Does it not play automatically for you on the sound to name card?
I am using javascript to make it play.

Nope, the new deck is not auto-playing on my system, neither on Linux Mint, nor on Windows.

On Linux Mint, auto-play only worked for me with the "“Audio with url from html (autoplay)” card.

However, i want to stress, that when in click on the audio button, its playing the audio. So in that respect its working perfectly fine, only the auto-play is not working.

I will try to rework the way a sounds and images are chosen and maybe be able to use autoplay instead of javascript then

1 Like

I just tested on Linux Mint on a virtual machine and it works for me. Are you sure you have the latest version of the deck?

Ok i thought i had the newest deck but i’m not sure. At least the replay button style changed from your original deck, so i’m pretty sure it was not the original one, which i imported into Anki.

However, i redownloaded the deck, and now everything works, including the autoplay :smiley:

Perfect! Yeah I uploaded twice, where I must have fixed it in the second upload.

1 Like