Trying to update via export / reimport - but getting duplicate cards instead

If I’m reading the manual correctly you should be able to export notes as plain text and edit them, then when you reimport them the original notes should be updated, meaning you don’t lose the history / scheduling info.

You have to import into the same note type and make sure that the first field is not altered.

What I did was:

  • put some notes into a subdeck and exported the as plain text
  • opened the .txt file in Excel and edited the data, without changing the first column
  • pasted the Excel data back into the .txt file (can’t save in UTF-8 directly from Excel) and saved it in Notepad
  • reimported the .txt file

In the last step, Anki suggested the right note type but wanted to put it in a different deck. I selected the subdeck the notes had originally come from.

The notes were imported as new notes rather than replacing/updating the originals.

Where did I go wrong?

I’m not 100% sure if it’s the first field that has to be the same or whatever field is used to index the cards, but in this case that would be the first field anyway.

Did you make sure the highlighted option is selected? The default is import duplicates, so maybe you have missed changing this.


OK I’ll take my stupid question of the week award and slip quietly out the back :smiley: