Title bar is not black when using Dark Mode on Windows

The title bar is not black when using Anki in dark mode on Windows 11.

What’s your version information (from Help > About > Copy debug info)?

For me (version info below) – Yes, you’re right for an unfocused window, but for the focused window it appears to be fine.

It looks like it’s doing the identical color switching as on Light Theme – focused window has gray bar, unfocused window has white bar. For Dark Theme, the unfocused window title bar should either not change (still gray), or should get a darker color.

[Preferences > Theme > Dark]

[Preferences > Theme > Light]

Version info –
Anki 24.06.2 (33a92379) (ao)
Python 3.9.18 Qt 6.6.2 PyQt 6.6.1
Platform: Windows-10-10.0.22621

Anki 24.06.2 (33a92379)  (ao)
Python 3.9.18 Qt 5.15.2 PyQt 5.15.5
Platform: Windows-10-10.0.22621

For me, it’s white whether the window is focused or not. Perhaps due to qt5 ?

1 Like

Definitely could be a Qt difference. Thanks for posting that. It will help the devs figure out what can be fixed!

If it’s a Qt5-only issue, this is not something that is going to get fixed, as Qt5 is no longer being updated by its developers.

Even in Qt6 though – the title bar of the unfocused window changes to white despite the Dark theme. Is that unfixable as well?

There might be hope for Qt6, but it’s not something I’ve looked into I’m afraid.

1 Like

Can’t reproduce in Anki 24.06.3 running on Windows 11.

On my Windows 10 computer, using Anki 24.06.3 qt6, I can change Anki’s title bar to black by setting the computer’s system theme to dark.

1 Like

I’m not a regular Windows user, and don’t know what’s considered normal here.

@abdo, if you think Anki’s doing something wrong here and feel like digging into it, it would be appreciated. :slight_smile:

@qubist-pixel @vaibhav @jcznk
There are a couple more variables here that could also account for why we’re seeing different things. For each of you –

  1. Do you have the Anki theme set to Dark or Follow System?
  2. Do you have the Windows mode [Settings > Personalization > Colors] set to Dark or Light (or Custom)?

On mine [Windows 11] –

  1. Anki theme > Dark
  2. Mode is Custom, so it’s broken out into 2 settings – default Windows mode > Dark – default app mode > Light

On mine [Windows 11] –

  • Anki theme: Follow System
  • Windows color mode: Dark

Windows 10, Anki 24.06.3, qt6

  1. Anki theme: either Dark or Follow System
  2. Windows color mode: Dark

@Danika_Dakika
Anki Theme : Follow System
Windows : Dark

@dae : I tried the qt6 build and it does not have this issue. But @Danika_Dakika has set the app mode to Light in Windows and Dark Theme in Anki. Unfocused Anki windows have light title bar which is abnormal behaviour.

@abdo Before you spend any time on this –

Since the initial issue is Qt5 – it is probably not fixable, yeah?

The separate Qt6 issue that I stumbled into is that when Windows is set to use a “Default App Mode” of Light – Anki being set to Dark Theme does not override that for the title bar of the unfocused windows.

image

If that’s as bad as life gets for me – I’m doing fine. So don’t put effort into this one on my account. :sweat_smile:

I can reproduce this. Fixing it apparently requires registry hacks: Title bar always white on windows 10 · Issue #834 · equalsraf/neovim-qt · GitHub