Tibetan input not working

I am trying to type Tibetan words into the ‘add note’ dialog of Anki 2.1 on Mac OS X, using the inbuilt Mac Tibetan input. Tibetan makes heavy use of stacked letters, which are typed by pressing the ‘f’ key. This causes the next typed letter to appear under the previous one, so ར + ག + ཡ becomes རྒྱ. Unfortunately, in Anki these letters currently do not stack properly (though they do in every other application); instead they appear superimposed over one another, with dotted circles above or below. I have a similar problem in typing Nepali, where the ‘viram’ character, which has a similar stacking effect, is typed twice whenever the key is pressed.

The manual states that the toolkit Anki is built on has some problems handling certain types of input, but there are shared Tibetan decks where the text displays properly. How can I achieve this in my own Anki setup?

1 Like

Information for anyone that finds this - it turns out the two issues I identified are related and are the subject of ongoing work, according to this ticket

I hope a fix can be found soon - many users no doubt want to use devanagari on their cards!


Just as an update to this - the underlying bug has apparently been fixed in Chromium. Is it possible to determine when the change will make its way into Anki?


Interesting, I’m using Anki 2.1.38 /MacOSX 10.15.7 and Tibetan stacking via the default Wylie input works just fine. The default card types have smaller font sizes so the glyphs do smear together but the actual stacking works just fine.

It’s a known issue concerning html/web browsers and proving enough space for stacked letters with html pages:

1 Like

It may take 6 months or more before the toolkit Anki is built on updates to a newer Chromium.

You are right! The stacking works just fine with the Wylie input, but not with the QWERTY input that I have been using until now. The problem is solved!

EDIT: well, not quite solved. If I type ‘stong’, for example, the glyph for ‘t’ is followed by the glyph for ‘to’, so the ‘t’ appears twice. This doesn’t happen in e.g. the URL bar of Safari. Hopefully when the toolkit updates this will go away.

Interesting, I typed སྟོང་པ་ཉིད། without issues with 2.38/MacOSX 10.15.7 into Cloze Text and Extra fields, and browser search fields. I use larger font text sizes for Tibetan and mixed Tibetan/English text CSS settings myself.

To be fair, I only type in shorter words directly to Anki, for any longer and stacked things I use an external editor – need to figure out the right CSS settings to allow the glyphs to stack up properly when editing, they show up usually fine. The Mac keyboard has some quirks with the Wylie input such as after ག་ you hit space and it does a delete – doubt that will ever be fixed (even after filing bug reports), just happy all this was added in ten years’ ago.

I’m having the same issue still!
Makes it quite hard to use Anki with Tibetan, as I have to first write the word somewhere else and then copy it into Anki when making new cards for example.

Has the toolkit already been updated? The original bug seems to have been solved 8 months ago.
Should I try the beta channel?

Thanks! <3

Work on updating to the latest toolkit version will start in Oct


Thanks so much for all your work! :slight_smile:

1 Like